Clicking the teardrop should also hide the bookmarks bar

RESOLVED DUPLICATE of bug 167599

Status

Camino Graveyard
Toolbars & Menus
--
enhancement
RESOLVED DUPLICATE of bug 167599
14 years ago
14 years ago

People

(Reporter: Shay Elkin, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

unspecified
Camino1.0
PowerPC
Mac OS X

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040623 Camino/0.8
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040623 Camino/0.8

Clicking the teardrop button on the titlebar hides the toolbar, but not the
bookmarks bar. 

I think it should also hide the bookmarks bar.

Reproducible: Always
Steps to Reproduce:
1. Click the teardrop button on Camino's titlebar
2. 
3.

Actual Results:  
Only the toolbar disappers, and the bookmarks bar remain visible.

Expected Results:  
Both the toolbar and the bookmarks bar should be hidden
(In reply to comment #0)
 
> I think it should also hide the bookmarks bar.

Is it stated somewhere in HIG ?
 
> Reproducible: Always
> Steps to Reproduce:
> 1. Click the teardrop button on Camino's titlebar

I can confirm this but do we want to fix this ?

> Actual Results:  
> Only the toolbar disappers, and the bookmarks bar remain visible.
> 
> Expected Results:  
> Both the toolbar and the bookmarks bar should be hidden

Mail.app behave the same way. Reporter could you check HIG to see what is said
on the subject ? 
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> > I think it should also hide the bookmarks bar. 
> Is it stated somewhere in HIG ?

http://developer.apple.com/documentation/UserExperience/Conceptual/OSXHIGuidelines/XHIGWindows/chapter_8_section_3.html#//apple_ref/doc/uid/20000961/BABIFCFJ

"If your application uses toolbars as part of a window with other content,
include a control in the window’s title bar for showing and hiding the toolbar"

The bookmarks bar is a toolbar, is it not?
 
> Mail.app behave the same way. Reporter could you check HIG to see what is said
> on the subject ? 

Mail.appp doesn't have two toolbars: when you click on the teardrop icon, the
toolbar is hidden, while the status bar remains visible. 

In OmniWeb 5, however, clicking the teardrop icon hides both it's toolbar and
bookmarks bar.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Camino1.0

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 167599 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.