Freezes when I go to that page in Firefox 0.9.1

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Chris Ruddy, Assigned: Blake Ross)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.8

Firefox 0.9.1 freezes when I go to http://forum.gentilefanclub.com/forgot.php. 
All other pages on that site work fine, and
http://forum.gentilefanclub.com/forgot.php works in IE 6 and Firefox .8 and earlier.

Reproducible: Always
Steps to Reproduce:
1. Click on a link to "http://forum.gentilefanclub.com/forgot.php" or enter it
in the Address bar.

Actual Results:  
Firefox 0.9.1 freezes.

Expected Results:  
Displayed the page.

Help > About says this is Firefox 0.8 but it is really 0.9.1.

TalkBack did not record the freeze, but Microsoft's equivalent did.

This is a page I developed in the Fall of 2003 and tested in Firebird 0.7.  It
also works in Firefox 0.8.

I commented out the HTML, leaving the PHP session code and went to this page. 
It did not freeze.  I then commented out the PHP, leaving the HTML and it froze.

The HTML is valid HTML 4.01 Transitional.

I tried disabling all of my extensions, but it still froze.

Updated

14 years ago
Assignee: bugs → firefox
Component: Web Site → General
QA Contact: firefox.general

Comment 1

14 years ago
Works for me.

Started with a clean profile, no extensions installed.

- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040703
Firefox/0.9.0+
- Microsoft Windows 2000 Pro 5.00.2195 SP4

Updated

14 years ago
Severity: normal → critical
Keywords: hang

Comment 2

14 years ago
This is familiar to other reports that have claimed hangs/100% cpu with forums.
 I cannot find any of them now, but they all share one trait: reporter claiming
0.9 or 0.9.1 while the build ID reports 0.8.

Reporter: have you installed 0.9.1 on top of 0.8?  If so you can please try a
clean installation and report back here!

Comment 3

14 years ago
I get many 100% cpu freeze in firefox 0.9.2 (About box says 0.9.2 too).
Seems to happens in some forms, on sites that uses sessions. It happens in
FlashFXP Customer portal interface, and in vBB 2.x admin interface, in the IP
addresses form... Still trying to reproduce or to find a pattern.

Comment 4

14 years ago
(In reply to comment #3)
> I get many 100% cpu freeze in firefox 0.9.2 (About box says 0.9.2 too).
> Seems to happens in some forms, on sites that uses sessions. It happens in
> FlashFXP Customer portal interface, and in vBB 2.x admin interface, in the IP
> addresses form... Still trying to reproduce or to find a pattern.

http://bugzilla.mozilla.org/show_bug.cgi?id=253833
(Reporter)

Comment 5

14 years ago
I sent the following in an email to bugzilla-daemon@mozilla.org on 7/4/4, but I
guess that was not the right thing to do because it did not end up here:


I think the Form Hanging issue is profile related and separate from, but highly
correlated with, the Build ID error.  Here's why:

A few days ago, I installed 0.9.1 over 0.8 without uninstalling 0.8.  When asked
to import a profile, I chose to import my 0.8 one.  When I went to
http://forum.gentilefanclub.com/forgot.php, it hung.  The Build ID said 0.8.

Earlier today, I installed 0.9.1 over 0.8 on my parents computer without
uninstalling 0.8.  When asked to import a profile, I chose not to import one. 
When I went to http://forum.gentilefanclub.com/forgot.php, it displayed
correctly and did not hang.  The Build ID said 0.8.

Just now, when I got your email, I went to Add/Remove Programs to uninstall
0.9.1.  However, both it and 0.8 were listed.  When I tried to uninstall 0.8 it
gave me an error about there being nothing in the uninstall log in the registry
(sorry, I did not record the error).  I then uninstalled 0.9.1 without incident
and then tried to uninstall 0.8 again.  I got the same error, but this time it
was removed from the Add/Remove Programs list.  I reinstalled 0.9.1.  It did not
ask me to import a profile, it just used my old one.  When I went to
http://forum.gentilefanclub.com/forgot.php, it hung.  The Build ID said 0.9.1.

I uninstalled 0.9.1 again and removed the Mozilla and Phenoix directories from
the Application Data directory in my home directory.  I reinstalled 0.9.1.  It
did not ask me to import a profile, it gave me a new one.  When I went to
http://forum.gentilefanclub.com/forgot.php, it displayed correctly and did not
hang.  The Build ID said 0.9.1.

So basically, the three times I was supposed to delete my profile before
upgrading Fire* I didn't and nothing went wrong, but the one time I didn't have
to, I didn't and something didn't work.  I won't hold it against you :)

The four unique scenarios show two different problems, one with the Build ID not
changing when you install 0.9.1 without first uninstalling 0.8 and one with
hanging on some pages with forms when you import your 0.8 profile into 0.9.1. 
By the way, in the first scenario, I copied the HTML out of
http://forum.gentilefanclub.com/forgot.php, saved it locally and ran it locally.
 It displayed correctly without hanging.  I hope all of this helps and I hope I
did not confuse you too much :)

I would like to thank you and the rest of the Firefox Team for you help with
this bug and for making such a wonderful product.  With every release I tell
more and more people about Firefox, and since CERT's announcement last week I am
doing everything I can do get people to switch away from IE to Mozilla or Firefox.

-Chris 

Comment 6

14 years ago
-> WFM by reporter's comment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

14 years ago
The problem is back. I am using 0.9.3, and that is what it says in Help > About,
but when I go to http://forum.gentilefanclub.com/forgot.php, Firefox hangs.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
WFM
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
(Reporter)

Comment 9

14 years ago
WFM in 1.0PR

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.