better error message for content auto-detection needed

RESOLVED DUPLICATE of bug 285517

Status

Core Graveyard
File Handling
--
enhancement
RESOLVED DUPLICATE of bug 285517
14 years ago
2 years ago

People

(Reporter: Peter Oliver, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510 Galeon/1.3.15
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040616

http://www.triv.org.uk/~mavit/typescript is a text file containing occasional
control characters.  As I understand it, it is valid ISO-8859-1, and
http://en.wikipedia.org/wiki/ISO_8859-1#ISO_8859-1_vs_ISO-8859-1 seems to
support this view.  The web server delivers it with the header "Content-Type:
text/plain; charset=iso-8859-1".

However, Mozilla has other ideas.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.triv.org.uk/~mavit/typescript

Actual Results:  
A box popped up saying:

    The file "typescript" is of type application/octet-stream, and Mozilla does not
    know how to handle this file type.  This file is located at:
    
    http://www.triv.org.uk/~mavit/
    
    What should Mozilla do with this file?
    
     ( )  Open it with the default application
     ( )  Open it with [                          ] [ Choose... ]
     (*)  Save it to disk

The dialogue box says that the file is of type "application/octet-stream", even
though the web server explicitly said that it's a "text/plain".

Note also that there is no option to open the contents directly in Mozilla
(although it appears this is already being tackled in bug 57342).

Expected Results:  
I'd expect the contents of the file to be displayed on the screen, which is what
used to happen.

I appreciate that perhaps most supposedly text/plain files containing
non-printable characters are actually binaries, and you could argue that if a
file contains control characters then it's not suitable for displaying anyway,
so perhaps asking the user what to do isn't a bad idea.  However, you should
explain what's going on, rather than "lying" about the content type to the user.
 Something like 'The file "typescript" claims to be of type text/plain, but
looks more like an application/octet-stream.  Mozilla does not know...' seems
less likely to cause confusion to web developers.


Also reproduced with Firefox 0.8 on Windows 2000.

On Linux, with Firefox 0.8 as downloaded from Fedora, the text is always shown
inline.

Updated

14 years ago
Severity: normal → enhancement
OS: Windows 98 → All
Hardware: PC → All
Summary: text/plain; charset=iso-8859-1 misidentified as application/octet-stream → better error message for content auto-detection needed

Comment 1

14 years ago
For reference this is one of the special cases from bug 220807.  If you change
the iso to Iso it works fine.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
fixed later in bug 285517, because I couldn't find this bug :(

*** This bug has been marked as a duplicate of 285517 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Keywords: helpwanted
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.