Invalid images should render the "broken image" icon and not just the alt text

VERIFIED WONTFIX

Status

()

Core
Layout
P3
normal
VERIFIED WONTFIX
18 years ago
16 years ago

People

(Reporter: Henrik Gemal, Assigned: troy)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
if you go to:
http://www.cdrom.com/pub/png/pngsuite.html
and check under the "Illegal and/or corrupted PNG images:" section you just see 
the alt text for the images.
In Netscape 4.7 you get the broken images.

Expected:
You'll get the broken image icon and also the Alt text, properly as a tooltip 
when tooltips start working in Mozilla.
(Assignee)

Comment 1

18 years ago
We're doing exactly wthat the HTML4 spec says should happen which is when an 
image can't berendered you render the alternate content instead.

Navigator 4.x and IE have always done this incorrectly...
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

18 years ago
Ahh.. I wasn't aware that NS47 and IE was doing it wrong.
Thanx...
(Assignee)

Comment 3

18 years ago
We didn't know about it either until Ian Hickson brought it to our attention. 
But it's there in the HTML4 spec and Lynx has been doing it that way for years

Comment 4

18 years ago
Marking as verified won't fix per last comments.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

18 years ago
*** Bug 42364 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
*** Bug 153320 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.