When preferences for opening links using middle click in new window AND tabs are set to FALSE, links that are middle-clicked are still opened in a new window

RESOLVED DUPLICATE of bug 266985

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 266985
14 years ago
13 years ago

People

(Reporter: msalem23, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

I want to make it so that when I click a link using the middle-click on my
mouse, NOTHING happens and the link does NOT open because I hate it when I
accidentally open links with the middle click. In other words, I only want the
LEFT-mouse button to work for opening links. So I typed "about:config" in the
Firefox address bar and I set the values for middlemouse.openNewWindow AND
browser.tabs.opentabfor.middleclick to False. After doing so, I closed Firefox
completely and re-opened it to ensure that the changes took effect. I went to a
site with links on it and clicked one of the links using middle-click (to see if
it worked) and unfortunately the link opened in a new window. The only thing I
use middle-clicking for is Auto-Scrolling; NOT for clicking links. Even after
setting BOTH of those preferences to False, links that are clicked using
middle-click still opened.

Reproducible: Always
Steps to Reproduce:
1. Type "about:config" in the Firefox address bar.
2. Type "middle" for the filter, and press enter.
3. Locate the value for middlemouse.openNewWindow, right-click it, and click
"modify"
4. Change the value to False and press enter
5. Locate the value for browser.tabs.opentabfor.middleclick, right-click it, and
click "modify".
6. Change the value to False and press enter.
7. Go to any web site with links on it, and click one of the links using the
middle-click on your mouse.

Actual Results:  
The link opened in a new window.

Expected Results:  
Nothing at all.

Comment 1

14 years ago
Same as bug 266985?
This bug was last touched before 1.0.4. Is it still reproducable?
Try the latest branch build (1.0.5): http://www.mozilla.org/products/firefox/
Try the latest nightly trunk build (v1.0+): http://www.mozilla.org/developer
(Reviving old UNCONFs)

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 266985 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 4

13 years ago
I would like to know how to ignore middle mouse clicks in Firefox 1.5.  I have my mouse settings in the windows control panel set globaly, and firefox is overriding these settings.  A simple user-pref, perhaps, a "middlemouse.ignore", could sovle this issue?
You need to log in before you can comment on or make changes to this bug.