A trailing tilde (~) in a folder name makes the folder disappear

RESOLVED DUPLICATE of bug 94124

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 94124
14 years ago
14 years ago

People

(Reporter: Durk, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040209 Firefox/0.8 (Oxs G7 SSE optimized)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040209 Firefox/0.8 (Oxs G7 SSE optimized)

Creating a folder with a trailing tilde (~) in the name makes the folder
disappear after a restart of Thunderbird (0.7.1).

Reproducible: Always
Steps to Reproduce:
1. Create a subfolder in Local Folders with a trailing tilde (~), for example "bla~"
2. Close Thunderbird.
3. Start Thunderbird.

Actual Results:  
The created folder disappeared.

Expected Results:  
Keep showing the folder.

To work around this bug, go to your Thunderbird profile on the filesystem and
search the disappeared folder name. Then remove the the last tilde (~) out of
the two file names.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 94124 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
"~" problem in folder name is probably different from "#" problem.
  "~" is home directry indicatior on Unix,
  but "#" is delimiter of anchor name in URI.
So I think "~" problem should be maintained separately although mentioned in Bug
94124 Comment #12 in the past.

Please note that "." is not a real "illegal file name character" but is listed
in Bug 124287(meta bug for illegal chars) for tracking, and that starting "."
problem(Bug 229522) and ending "." problem(Bug 117840) is handled by separate
bugs by developer since cause of problem is different ;
  Starting "." is hidden file indicator on Unix,
  but ending "." is no file extention indicator on MS Windows.
  (ending "." is removed by MS Windows since this is delimiter of file) 
  (extention, but because of no file extention string, real file name on 
  (MS Windows does not contain ending ".")

My recomendation is;
 (1) Re-open this bug and set as NEW
 (2) Set dependency of this bug on Bug 124287 (meta bug for illegal chars)
 (3) Let reporter of Bug 94124 Comment #12 to know this bug
You need to log in before you can comment on or make changes to this bug.