Can't use right-click 'Paste' at end of composer window

VERIFIED WORKSFORME

Status

Thunderbird
Message Compose Window
VERIFIED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Wayne Stidolph, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040614 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040614 Firefox/0.8

Want to paste some text at end of message using mouse context menu (right-click,
Paste). But, right-click in last space highlights entire message so Paste
replaces entire message rather than appends text

Reproducible: Always
Steps to Reproduce:
1. Compose new message and put text in composer window
2. Highlight text from middle of message, right-click, Copy
3. Position mouse cursor at very end of text in composer window
4. Right-click to bring up context menu; observe entire message highlighted

Actual Results:  
All text selected (independant of previous cursor position); context menu active

Expected Results:  
Cancelled existing highlight; positioned cursor at end; brought up context menu
without

Comment 1

14 years ago
I have a similar problem with Thunderbird version 0.8 (20040913) on Windows XP.
It is always reproducible.
When I forward a message, the forwarded text in the compose window is in
preformat style.  I right click in the text window and it selects all the text
(so if I hit paste the text dissappears).  
If I change the formatting to a style other than preformat it does not happen
and if I paste from the paste icon or the Edit menu it does not happen (although
the cursor moves up one line from the bottom after I paste).

Comment 2

13 years ago
Wayne Stidolph, are you still seeing this symptom?  I am unable to reproduce it 
with TB 1.0, Win2K.

If the problem appears to be solved, please mark this bug
  Resolved | WorksForMe
(Reporter)

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.