none of the extensions have download only links

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Public Pages
--
enhancement
RESOLVED WONTFIX
14 years ago
3 years ago

People

(Reporter: robertlmarti, Assigned: wolf)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040616

One of the good things about the older setup is most every extension had some
sort of download and uinstall later link (or you could r-c the install link).
Under the current system you maybe could do a r-c but it would be nice if you
could hit a link that was a just download it link || or maybe it could be done
as a "shopping cart" where you pick your extensions and then they could be qued
in sets of 3 or 4.

Reproducible: Always
Steps to Reproduce:
no steps except trying to install more than one extension

Comment 1

14 years ago
We have a Download This link already.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

14 years ago
http://update.mozilla.org/extensions/showlist.php?type=E&application=thunderbird&numpg=

and where would the download link FOR EXTENSIONS be??
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Assignee)

Comment 3

14 years ago
There's a download link for themes pages.. Because Themes use a JavaScript
install-trigger.. and Firefox/Mozilla don't directly attempt to install themes
if you provide a download link. The install links disable right-click/save link
as.. because of the JS used.

Extensions are another matter.. There'd be no difference between the current
install link and a proposed download link.. this has been discussed before.
Firefox/Mozilla both attempt to handle XPIs sent via http (with the
application/x-xpinstall mime-type)  and via ftp, if they have the .xpi
extension. The files are hosted on mirrors, therefore there's a redirect
involved so custom http headers cannot be inserted except from the remote mirror
servers which we don't have that kinda access to.
The workaround is to right-click and save link as... as the tooltips on the
install now buttons already suggest. :-)

WRT Thunderbird, that's a seperate issue, that's already been filed.
It's Bug 247200.

-> WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

14 years ago
Component: Update → Web Site
Product: mozilla.org → Update
Version: other → unspecified
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.