status bar messages generated by script appear with other tabs in same window

RESOLVED DUPLICATE of bug 104532

Status

SeaMonkey
Tabbed Browser
RESOLVED DUPLICATE of bug 104532
14 years ago
10 years ago

People

(Reporter: Ernest Cline, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616

The page I am referring to runs a script in the background that continuously
alters the window.status.  If I go to other tabs loaded in the same window, that
status bar message continues to change.  It does not affect the status bars of
other windows at all. Status bar messages not generated by scripts that are
related to hovering over a link do get priority, so this isn't as bad as it
could be, but the status bar text should be handled on a per tab, not a per
window basis in my opinion.

Reproducible: Always
Steps to Reproduce:
1. Load http://www.freewebs.com/afip/ into a tab andd any other page into
another tab in the same window.
2. View the other tab.

Actual Results:  
The status bar text changed in the other tab as if the
http://www.freewebs.com/afip/ were being looked at.

Expected Results:  
Showed status bar text generated only by the page loaded into that tab.

For some pages, I need to first hover over a link to generate a status bar
message for that page and then back to a place where there should be a blank
status message in order for the status bar to start using the script generated
messages from the http://www.freewebs.com/afip/ tab.

*** This bug has been marked as a duplicate of 104532 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.