login button doesn't work




14 years ago
14 years ago


(Reporter: alex leung, Assigned: Blake Ross)


Firefox Tracking Flags

(Not tracked)





14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040702 Firefox/0.9.0+

the login button of Mozillazine forum's login page doesn't work with installer
build. Zip build works as it should.

Reproducible: Always
Steps to Reproduce:
1. uninstall previous FF installation
2. delete profile(s)
3. cleanup registry
4. install Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040702 Firefox/0.9.0+ installer build
5. go to Mozillazine forum and login

Actual Results:  
nothing happen after the login button is clicked.

Expected Results:  
login sccessfully and redirect to forum home.


14 years ago
Assignee: bugs → firefox
Component: Installer → General
QA Contact: bugzilla → firefox.general

Comment 1

14 years ago
The following installer build also doesn't work:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040702

Comment 2

14 years ago
I can confirm this bug, and it is not only for the mozillazine forums, any 
submit button does not work.

Comment 3

14 years ago
I can confirm it. I had 20040702 version installed for my brother and not even
Google's "search" was working ! As his profile directory was still using the
name "Phoenix", I cleaned it entirely before installation. This is consistent
with the steps followed by Alex.
In order to get himself out of this, he reinstalled the release 0.9.1 (I guess
*without* cleaning) and now it works.

Comment 4

14 years ago
Does not work for me too (Win XP Pro).

Clean install from branch Gecko/20040705(exe installer) does not work - buttons
do not submit. I appeared some 3 days ago.

Workaround: I have downloaded the same zip version and extracted it to temporary
directory, launched firefox.exe from that dir, closed it - and now the original
version in "c:\Program Files\Mozilla Firefox" works :-D


14 years ago
Flags: blocking-aviary1.0RC1?
Flags: blocking-aviary1.0?

Comment 5

14 years ago
Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

I have NOT encountered this bug using the above nightly (Windows ME installer).
 I installed it after uninstalling and completely deleting 0.9.1 milestone but
still using same profile.

BTW, uninstalling 0.9.1 doesn't completely delete some of the files in the
subdirectories.  Could that be relevant to this bug?

Comment 6

14 years ago
Can someone please confirm this bug ? I installed the 8th July branch installer 
version on a system that never knew Firefox before and there ! I'm forced to 
use IE to file this comment. The "Commit" button doesn't do anything. 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040708 

Given that installing the 0.9.1 release afterwards fixes the bug, there's a 
corrupt (or missing) file somewhere ...

Comment 7

14 years ago
Possible dupe:http://bugzilla.mozilla.org/show_bug.cgi?id=250209

Bug still here:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040708 Firefox/0.9.0+

Note the yahoo.com and groups-beta.google.com, one of the buttons does work, 
others don't.

From yesterdays attempt to log this stuff:

forum.mozilla.org logon still not working.  complete removal and clean 

By complete I mean - remove program, delete everything, run RegCleaner, then 
delete the registry entries for Mozilla and Netscape left behind.  reboot.  
Install latest.  Reboot.  No extensions.  new profile.

Ian wrote:

> Sorry for emailing - see last comment (no IE for this little black duck).  If 
you want to email me use the cc: address.
> Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.0+
> Completely clean install - everything removed (profiles, extensions etc), no 
extensions.  Just downloaded      4550 KB      7/8/04      2:11:00 PM.  Will 
try again after doing another clean install and running RegClean.
> Javascript is enabled (well the box is ticked).  Tools Javascript console is 
> http://groups-beta.google.com/ - search button on front page does not work, 
buttons on logon page DOES  work.
> my.yahoo.com logon working
> mail.yahoo.com send button not working
> http://www.free-dc.org/forum/ logon button not working
> slashdot.org logon button not working - recognises site, asked if I wanted to 
save  logon stuff, then does nothing.  Repeatedly pressing, closing FF and 
rebotting - no difference
> forum.mozilla.org logon still not working
> bugzilla Additional Comments commit button not working

Comment 8

14 years ago
This bug is weird.
This time, to solve another unrelated problem (the Javascript InstallTrigger
link for "(Install theme)" not working at all), I removed anything I found
related to Firefox after the regular uninstallation : appdata\mozilla,
uninstallfirefox.exe (or is it the other way round ?), uninstallmozilla.exe (I
also uninstalled Mozilla 1.8a2). I didn't looked at the registry however.
Then I installed the latest 0.9 (i.e. Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.7) Gecko/20040710 Firefox/0.9.0+). BTW this nightly has a Talkback
error, I'll file another bug for this if nobody did it yet.
And it works now : Google, Mozillazine forums, etc.
So, for *me*, the bug is gone.

Comment 9

14 years ago
This version appears to be working properly

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040710 Firefox/0.9.0+

fix is probably from http://bugzilla.mozilla.org/show_bug.cgi?id=250209
Yes, this work with Windows branch build 2004-07-12-09-0.9

Bug 250209 should have been duped to this. But since it's already been verified
fixed, I'll dupe this one to it.

*** This bug has been marked as a duplicate of 250209 ***
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE


14 years ago
Flags: blocking-aviary1.0PR?
Flags: blocking-aviary1.0?
You need to log in before you can comment on or make changes to this bug.