JavaScript based on Microsoft Script Library (used by Cisco Call Manager v. 3.3) are not working...

RESOLVED DUPLICATE of bug 248018

Status

Tech Evangelism Graveyard
English US
RESOLVED DUPLICATE of bug 248018
14 years ago
3 years ago

People

(Reporter: Maciej Szeliga, Unassigned)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

This is more an incompatibility issue than an error, those scripts didn't work
in Mozilla 1.5 either... those scripts are Java Scripts not VBScripts

Sript library :

Microsoft Script Library
Visual InterDev 6.0 Remote Scripting utilities for client
Copyright 1998 Microsoft Corporation. All Rights Reserved.


Info in JavaScript Console : 

Error: [Exception... "'Permission denied to get property
XULElement.selectedIndex' when calling method:
[nsIAutoCompletePopup::selectedIndex]"  nsresult: "0x8057001e
(NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame ::
http://cm1.kommunekredit.dk/ccmadmin/_ScriptLibrary/rs.htm :: _MSRS_startRequest
:: line 263"  data: no]
Source File: http://cm1.kommunekredit.dk/ccmadmin/_ScriptLibrary/rs.htm
Line: 263

Error: document.all has no properties
Source File: http://cm1.kommunekredit.dk/ccmadmin/main.asp
Line: 133

...this is propably more M$ (or Cisco's) issue than Yours, but I've got a silly
feeling that You may be more interested in solving it than they would be...

Reproducible: Always
Steps to Reproduce:
1. load ccmadministrator page and log in
2. choose one of the menues in the menu bar
3.

Actual Results:  
nothing happens

Expected Results:  
menu unfolds

Comment 1

14 years ago
document.all is IE-specific script.

Cisco would have to redo their code to be more browser-neutral.

->TE
Assignee: firefox → english-us
Component: General → English US
Product: Firefox → Tech Evangelism
QA Contact: firefox.general → english-us

Comment 2

13 years ago
Do you have a cisco support contract?  Open a case, report the bug, and ask them
to create a publically viewable bug.  It works!  I did this and the Cisco SDM is
being modified to work with Firefox as we speak.  Email me if you want me to
post details.

Comment 3

10 years ago
This looks like a dupe of bug 248018 to me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
OS: Windows 2000 → All
Hardware: PC → All
Resolution: --- → DUPLICATE
Duplicate of bug: 248018
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.