crash if I open a new tab with control-t

RESOLVED DUPLICATE of bug 249688

Status

--
critical
RESOLVED DUPLICATE of bug 249688
15 years ago
11 years ago

People

(Reporter: ken, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

I start up mozilla 1.7, the main window loads; I press control-t, a new tab
opens for a moment and then mozilla crashes.  The terminal window I started
mozilla in gets the error message

Gdk-ERROR **: BadWindow (invalid Window parameter)
  serial 14430 error_code 3 request_code 61 minor_code 0

the "serial" number is variable, on two other tries it comes out 7809 and 6381,
the rest of the error message is invariant

this is absolutely reliable, happens every time I open a new tab with control-t
(right-clicking on a link works fine).  I tried installing mozilla 1.7
twice, I also tried mozilla 1.8a, it happens every time with all of these.  It
doesn't happen under mozilla 1.6, which I am therefore currently using.

I can hardly believe this bug exists and hasn't been reported before, but I
can't find it in the list of known bugs.

In case it matters, here's more about my system:
localhost:ken% uname -a
Linux localhost.nyc2.dsl.speakeasy.net 2.4.22-emp_2423rc2 #1 Tue Nov 25 12:59:33
EST 2003 i686 unknown
localhost:ken% more /etc/mandrake-release
Mandrake Linux release 8.2 (Bluebird) for i586
2.4.22-emp is a kernel customized by Emperor Linux (www.emperorlinux.com) for
laptops; I'm running on a sony vaio pcg-z505LS.

Reproducible: Always
Steps to Reproduce:
1.start mozilla, let first window load
2.press control-t
3.

Actual Results:  
mozilla opens a new tab for a moment and then crashes with above error message

Expected Results:  
open the new tab without crashing

Updated

15 years ago
Keywords: crash

Comment 2

15 years ago
Ken: Could you provide TalkBack incident ID?
(Reporter)

Comment 3

15 years ago
(In reply to comment #1)
> Same as Bug 249688 ?

Yes, this appears to be the same bug.  Sorry I didn't find it myself.  Ken
(Reporter)

Comment 4

15 years ago
(In reply to comment #2)
> Ken: Could you provide TalkBack incident ID?

I am not certain how.  I started [mozilla-dir]/components/talkback/talkback and
told it to leave the agent on.  Then I started mozilla 1.7 and hit control-t to
evoke the bug, mozilla crashed but the talkback agent didn't do anything.  What
should I be doing to hook talkback to the mozilla crash?   Thanks -- Ken

Comment 5

15 years ago
Ken: I'm not Linux user, so I could advice Mozilla 1.7 re-installation with
TalkBack enabled (AFAIK its optional extension in installer).

I'm marking bug as dupe of bug 249688.

*** This bug has been marked as a duplicate of 249688 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.