German special characters print as weird glyphs (eg. ö becomes u-ring)

RESOLVED WORKSFORME

Status

MailNews Core
Printing
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: Alan Plum, Assigned: Scott MacGregor)

Tracking

Other Branch
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; de-DE; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Win98; de-DE; rv:1.6) Gecko/20040206 Firefox/0.8

Mails with the ISO-8859-1 character set and umlauts (הצ�, ...) in them are
previewed correctly by Thunderbird's Print Preview, but then print with bogus
characters instead of the umlauts.
The printer software's print preview (if set to be called instead of the printer
upon telling TB to "Print") already shows these bogus characters, so the
transformation has to take place between the print command and the reception by
the print driver.

This might be an issue with non-ASCII characters in general and might occur with
other Mozilla products too.

Reproducible: Always
Steps to Reproduce:
1A. Open a mail with umlauts in them (German spam for example)
OR:
1B. Write yourself an e-mail with umlauts in it and open it upon receiving it
2. Open Print Preview for the mail
3. Print the mail
4. Stare at the result lying in your printer
5. Repeat
Actual Results:  
The umlauts are all wrong (� becomes z-dot, צ becomes u-ring, ...)!

Expected Results:  
The umlauts should be all right!

Problem occured with stable 0.5, 0.7.1 and 0.7.1 German (www.mozilla-europe.org).
The printer in question is a Hewlett-Packard hp deskjet 959c.

Comment 1

13 years ago
Alan Plum, do you have a sample message that exhibits the problem?  Please save 
it as a .EML file and attach it to this bug.
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Alan Plum, do you have a sample message that exhibits the problem?  Please save 
> it as a .EML file and attach it to this bug.

Eh. I would love to, but for some reason Thunderbird now keeps on crashing on me
whenever I try to save a mail.

Just copy these characters into an e-mail:

Ä ä Ö ö Ü ü ß

And print it.

If it doesn't come out the same way it looks on screen, I'm not imagining things.

Comment 3

13 years ago
WorksForMe, TB0.7, Win2K

Comment 4

13 years ago
Possible dupe of bug 103240 or bug 126806.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → EXPIRED
WFM with version 2.0.0.5pre (20070706) under WinXP.
Severity: major → normal
Component: General → Printing
Product: Thunderbird → Core
Resolution: EXPIRED → WORKSFORME
Version: unspecified → Other Branch
Component: Printing → MailNews: Printing
QA Contact: printing
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.