Add a pop-up alert window action when a message matches a filter

RESOLVED DUPLICATE of bug 11040

Status

MailNews Core
Filters
--
enhancement
RESOLVED DUPLICATE of bug 11040
14 years ago
10 years ago

People

(Reporter: Thomas Harold, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Similar to Bug 118952, except that I want the action to be a pop-up "new mail"
window similar to how newer versions of MS-Outlook alert the user.  

The reasoning behind this action is that not every e-mail that lands in my inbox
needs to alert me of new mail.  During my work day, I might have a dozen windows
open with the mail program buried in the background doing it's send/receive
every 10-15 minutes.  I need visual (and aural) notification that a project
request (or task request) has landed in my inbox and I need to take a look at it.  

The system tray notification is useless in this case because it alerts for every
message, not just ones that I'm looking for. The pop-up window should be capable
of showing multiple messages with at least the name of the sender and the
subject line of the message.  

Additional enhancements might include any or all of the following:

1) Allowing the filter to specify the foreground/background color of the message
line in the window.  That way, if 10-20 messages have queued up, the user can
visually see which ones might be more important then the others.  Maybe allow
the user to pick a custom icon/bitmap to display in a separate column.

2) Display the importance icon for the message in a separate column.  Maybe
display size and message attachment columns as well.

3) Messages should automatically be removed from the window as they are
opened/read by the user.  The window should automatically vanish once all
messages have been opened/read.  It should be possible to select multiple
messages to be opened at the same time.  (MSOutlook fails to do this.)

4) Alternate solution might be to just flash a customizable message down near
the system tray (similar to how "downloads complete" flashes there when Firefox
finishes downloading all of the queued files).  Disadvantage to that solution is
that it's not persistent and can be missed if the user walked away from their
desk for even a minute.  The pop-up window is more likely to be noticed upon
their return from lunch.  Flashing a customizable bit of text down by the
systray might be an additional option for the action (like color-coding the
notification).

5) Alternate action #2: Allow the action to change the system tray notification
icon (make it a different color, make it pulse/throb, etc.) until the user
brings the mail client to the foreground.

Reproducible: Always
Steps to Reproduce:
Why not just filter your messages to a seperate folder contained within the Inbox?

You would then only need some kind of notification to tell you that you had new
items in that folder (as they had been filtered), perhaps this would just be a
simple dialog stating "you have mail that matched xxx filter, do you wish to
switch to mail?". (Sound notifications - see bug 11040 or bug 118952).

Then with the folder view:

Item 1) can be done via the labelling option on filters - colours can be set up
in preferences, filter then can specify what to label it as. Once filter set up
then all messages matching that filter will be coloured as required in the
appropriate folder.

Item 2) can be done via choosing which columns to display in the folder pane -
click on the icon on the at the end of the headings in the list view and you can
select which can be done.

Item 3) would be the read/not read indication we currently have.

Items 4 & 5 would require other biff notification bugs to be sorted (there are
some around but I can't remember where they are).

So then all you would need extra is a "Notify user with Dialog" action being
added to the filters & it would only need to be a nice simple one that would
(probably) be easy to implement.
Product: MailNews → Core
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 3

13 years ago
(In reply to comment #1)
> Why not just filter your messages to a seperate folder contained within the Inbox?
> 
In my opinion this is not the same.
Sometimes one is waiting for an important email to arrive and wants a special
notification for it. So ideally I would create a filter for that person or
message title or content or whatever and I would activate the action that would
say "alert with a special pop-up dialog". Sometimes one receives various emails
so the common notification facilities aren't useful for this case.


> So then all you would need extra is a "Notify user with Dialog" action being
> added to the filters & it would only need to be a nice simple one that would
> (probably) be easy to implement.
>
Yes! That's right! Something simple could do the job!

Goodbye and thanks.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 11040
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.