Camino crashes on startup with Mac OS X Tiger WWDC build.

RESOLVED INVALID

Status

Camino Graveyard
General
--
critical
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: Mark Knopper, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({crash})

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/146 (KHTML, like Gecko) Safari/146
Build Identifier: July 4, 2004 nightly build

The application Camino has unexpectedly quit.

Date/Time:      2004-07-05 23:27:46 -0400
OS Version:     10.4 (Build 8A162)
Report Version: 2

Command: Camino
Path:    /Applications/Camino.app/Contents/MacOS/Camino
Version: 0.7.0 (0.8+)
PID:     411
Thread:  Unknown

Link (dyld) error:

unimplemented dyld function



Reproducible: Always
Steps to Reproduce:
1. Go to WWDC, get Tiger DVD. Install on powerbook.
2. Run Camino.

Actual Results:  
Brings up menu but crashes before first window displays.

Expected Results:  
Probably should not have crashed.
(Assignee)

Comment 1

14 years ago
yes, this is due to the check for prebinding not being implemented yet in
tiger's dyld. easy to fix. 

Updated

14 years ago
Keywords: crash

Comment 2

13 years ago
doesn't happen on newer adc builds according to people who have legal access to
them. perhaps best not to file bugs on tiger builds until a little later in the
game as tiger development is rapid and most camino developers don't have access
to builds anyway.

confirming that the following builds work on recent tiger build:
0.8.1
0.8.2rc
0.9 trunk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Assignee)

Comment 3

13 years ago
actually, this was perfectly valid and we fixed it by turning off prebinding. it
was crashing because a symbol used by the prebind process was not implemented.
You need to log in before you can comment on or make changes to this bug.