Location bar blank or shows obsolete URL after starting Mozilla with Mail

RESOLVED WORKSFORME

Status

SeaMonkey
Location Bar
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Douglas, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616

When I have email accounts that I want to check and download new msgs with
Mozilla, I sometimes start Mozilla through its Mail component (i.e. not starting
with Browser, e.g. Start > Programs > Mozilla > Mail). Mozilla Mail downloads
the new email and then I open a new browser window (I click on the [M] icon at
the bottom left of Mozilla's app tray). I then go to a website (any website)
either through bookmarks or typing into the Location Bar. This is where I find
the strange behaviour.

Reproducible: Sometimes
Steps to Reproduce:
1. Make sure there is some mail to be downloaded from an account you check with
Mozilla Mail
2. Start Mozilla Mail directly--not through the browser, but for example Start >
Programs > Mozilla > Mail
3. Let Mozilla Mail download the email
4. Click on the New Browser Window icon in the Mozilla app tray
5. Go to any website

Actual Results:  
From this point on, the Location Bar will:

a) continue to show the same original URL that I went to first but will not
update the location as I move from webpage to webpage (e.g. it will show
"bugzilla.mozilla.org" even though I am filing this bug report, which I'm
certain is not located at simply "bugzilla.mozilla.org" but has other stuff
after the domain name).

b) stay blank. The mini-icon that appears to the left of the domain name (e.g.
the Mozilla lizard to the left of bugzilla.mozilla.org) may change to reflect
the site that I'm visiting, but other than that, the Location Bar doesn't update
with the current location URL.

I can return to normal operation after I close Mozilla and restart it again.

Expected Results:  
Location Bar should update the URL address as you normally browse from website
to website.
(Reporter)

Comment 1

14 years ago
I tried to reproduce this bug just now by sending a message to myself, but it
didn't work. I don't know the exact circumstances that make this bug appear, but
I am certain that it happens from time to time. I hope that someone else has
experienced and noticed this bug. I have noticed it since Mozilla 1.4

Comment 2

14 years ago
resembles bug 144349, where this can happen if browser and composer are started
simultanously

Comment 3

14 years ago
BTW.. this is not a frequently reported bug, so a few questions:

Did you make a clean install? (After an uninstall)
Do you have any extentions installed? Additional themes?
Does the bug also happen with a new profile?
(Reporter)

Comment 4

14 years ago
To R.K.Aa:
--It does resemble bug 144349.

--Installation
Yes, this is a clean install. I got a new computer recently that never had any
Mozilla applications on it so this should be a clean installation. Of note: when
I installed, I chose a Custom selection of components (I selected Browser, Mail,
and Talkback--no DOM inspector, no Spell Checker, no Java since I already have a
JRE installed, etc.)

--Extensions
I have Adblock and Googlebar installed. No others.

--Profile
This is on a new computer and I created a new profile on it, but I did copy a
few elements from a profile on another computer, namely my bookmarks, address
book, cookies, passwords, and saved emails to be copied into the corresponding
Mail subfolders.

Comment 5

14 years ago
could you try to create a new mozilla profile and run *without* Googlebar and
Adblock.
(Reporter)

Comment 6

14 years ago
I've tried with a new profile but so far I have not been able to reproduce the
bug. However, as this bug seems quite elusive in the circumstances surrounding
its trigger, I can't say definitively whether the bug is rooted in an extension
or some other profile-specific feature.

I recently ran into it on my own personal profile again, but I wasn't paying
attention to the circumstances.

Will continue to monitor and keep posted.

Comment 7

13 years ago
Glad I'm not the only one with this bug.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.11) Gecko/20050728

I also use Adblock and Googlebar (no other extensions).

I'll have to do some more testing now with various combinations to see if it
still occurs.  I run into it frequenctly enough that I consciously open a
browser session before ever opening my email, so that I don't do the initial
browser open from an email link.

If I find anything, I'll report back.

Updated

11 years ago
Duplicate of this bug: 316858

Comment 9

11 years ago
After installing SeaMonkey 1.1.1, I no longer see this bug (which had been easy for me to reproduce, including in the previous release of SeaMonkey).

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070222 SeaMonkey/1.1.1

To be fair, I never did any testing without the two extensions I use (Adblock and Googlebar) -- and in fact, I changed to the "Plus" version of Adblock some time ago).

(In reply to comment #7)
...
> I also use Adblock and Googlebar (no other extensions).
...
> If I find anything, I'll report back.

Comment 10

11 years ago
WFM per comment 9
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.