radio buttons aren't repainted after changing the checked attribute

RESOLVED DUPLICATE of bug 46845

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 46845
13 years ago
13 years ago

People

(Reporter: Josh M. Sutter, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040210 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040210 Firefox/0.8

I'm dynamically build a radio group with information from a database. Which
radio button is checked comes also from the database. The HTML source code (->
View Page Source) is fine, the right radio button is checked, but it seems that
Firefox isn't repainting this (there's still the "old" radio button checked).

Reproducible: Always
Steps to Reproduce:
1.
2.
3.



Expected Results:  
The right radio button should be checked in the Browser (as it is in the HTML
source code -> View Page Source).

Comment 1

13 years ago
I have this same problem when dynamically creating the form from PHP code. At
this moment in time my code merely will place the entered values back into the
form. This works for every element in the form. I however noticed a problem when
I refreshed the page. The radio button would return to its previous, unchecked,
value even though the Show HTML shows that radio button to have a "checked"
attribute.

I have just now tested this in Internet Explorer and that does the expected
behavour (by checking the same radio button I had checked after submit).

Unfortunatly my code is only on localhost at the moment and so I cannot provide
a URL for you to be able to recreate the problem.

Running: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803
Firefox/0.9.3
OS: Windows XP Professional, Service Pack 2 (5.1 - 2600)
HTTP: Apache/2.0.50 (Win32) PHP/5.0.1 Server at localhost Port 80

Comment 2

13 years ago
Agree.

In basic HTML code (XHTML), the following works in IE:

<input type="radio" name="edit.type" value="edit" checked="checked"
class="radio" /> Edit Record<br />
<input type="radio" name="edit.type" value="delete" class="radio" /> Delete Record

(Edit Record is checked automatically.)
In Firefox it doesn't.

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.