Unable to import Contact Groups from OE Address Book (WAB)

RESOLVED DUPLICATE of bug 111019

Status

SeaMonkey
MailNews: Address Book & Contacts
--
critical
RESOLVED DUPLICATE of bug 111019
14 years ago
13 years ago

People

(Reporter: Emilio Trampuz, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616

Hi people at Mozilla!

This message should probably be forwarded to all the makers of Mozilla.  It's
basically a wish list.  But, more than that, ... it is the ESSENTIAL LIST.
Without this stuff, I can never seriously consider switching to Mozilla. Too
much simple, basic, essential stuff seems to be missing from Mozilla.

I considered switching from Internet Explorer/Outlook Express to Mozilla, so I
downloaded version 1.7.  Yes, it works, and it is heartwarming to see so many
enthusiastic souls supporting Mozilla. But, why are so many basic functions
missing from the most common part of Mozilla, namely: email?   One would think
that email (which we ALL use) would be the most supported function within
Mozilla. But some really basic stuff is totally missing, .... stuff that I need
to use every day. For example:

1. Multiple signatures. I need to be able to insert any one of a number of
signatures, depending on who I am writing to. Most of us wear different hats. I
have a business signature, a personal signature, and another one just for my ski
club correspondence.  Mozilla doesn't offer more than one fixed signature?  Why?
 Is it so hard to set up 3 or 4 small files, each with its own signature, and
make it possible to insert one or the other at will?

2. Groups (or Distribution Lists) in Address Book.  I use more than a dozen of
them in my OE Address Book (WAB), and each group consists of dozens or even
hundreds of addresses.  There seems to be no way of importing that info from the
OE Address book.  The import process brought in individual addresses. Any Groups
were stripped of all info and are now just dummy blank records in Mozilla.  I
don't have the time to re-create all my Groups (Distribution Lists) in Mozilla.
 Unless the capability to import Groups is added, Mozilla will simply be
unusable for me.   
(By the way, I don't like the idea of having to create separate address books
for all my groups anyway. I much prefer the system used in Windows Address Book
(WAB) where all groups of contacts are integrated into the address book.)
NOTE that I also need the ability to frequently and easily export (or Copy or
whatever) my complete Address Book, so that I can easily import it into my
Addresss Book on my laptop or on my wife's computer, .... so that they are all
in synch.  Can I do this in mozilla without loosing my Contact Groups?  Can I
import and export not only individual records but Groups as well?

3. Preference to DELAY sending messages. until I hit SEND/RECEIVE all.  I want
to avoid accidentally sending a message that I have not completed yet.  If that
happens in Outlook Express, the message simply gets moved to the Outbox, and I
can retrieve it and finish it before sending it off.  But, in Mozilla, if I
accidentally hit the SEND button, my message is gone!   I can't find any setting
in Preferences to change that behavior.  Why?  Is that so difficult to add to
Mozilla?

4. Preference to NOT connect and NOT get email right away when I start Mozilla.
Sometimes I just want to check my old email without having to connect to the
internet. I don't want to waste the extra time for the connection to happen.  I
don't want to start downloading new email. I just want to look at the existing
email.   I can do that in OE; why not in Mozilla?

5. No easy way to use CC and BCC fields.  Why are these fields not displayed by
default in the Compose window?  There are 3 or 4 useless empty lines in the spot
where these fields should be.  After much searching, I found a way to add email
addresses to those fields, ... but this stuff shouldn't be hidden on some other
screen or menu. It should be presented right there at the top of each new email.
 Just like in Outlook Express.  If you want us to leave Outlook Express, don't
take away or hide features.

6. No easy way to add a link. In OE, the moment I type in a web address or an
email address, they automatically become links.  Is that so difficult to achieve
in Mozilla?  Yes, I can go to the  Link button to make a new link.  But, how is
the average person to know that you are supposed to type in the "mailto:" word
in front of the email address to make it work as a link?  Only techno-geeks
would know that.  There is absolutely no guidance for the average person as to
what they are supposed to do to set up a link properly.  This was so elegantly
solved in Outlook Express that I find it hard to live without that feature. It's
just tedious to have to set up a link manually.

7. PLUGINS, PLUGINS and more PLUGINS!!!  Why?  Why not just give us a complete
package, so we don't have to deal with downloading all this additional stuff? 
Everybody these days needs PDF files, and Flash stuff seems to be everywhere on
the web too.  So, why not simply enable all this stuff in Mozilla by default? 
Give us a complete browser; not bits and pieces that we need to assemble
ourselves.  It's like instead of selling a car, you are giving us nuts and bolts
to assemble the car ourselves.

8. Too much reliance on editing the PREFs file.  It feels like editing the
Windows Registry.  Do you want Mozilla to be forever limited to geeks and
tech-wizards?  If Mozilla is ever to gain wider acceptance, it has to be easy to
use.  One should NEVER have to edit a file full of technical jargon that the
average person simply doesn't understand.

9. Lame spell-checker. I just ran this message though the spell-checker. It
didn't recognize the word "Mozilla"!!!  It also protested against words like
"Outbox" and "Plugin" and "BCC".  Aren't these common words within Mozilla
itself?  How can you use a spell checker that does not recognize the word
"Mozilla"?! This is just plain embarassing.

10. Simplicity is lacking.  There is a FAQ file where people asked questions
such as "Can this be done in Mozilla?"  And someone responds triumphantly: "Yes,
you can!"  But should it really be so complicated that we have to ask for expert
help?  No. All the features should be SELF-EXPLANATORY and self-evident. There
should be a button or a checkmark for eveything.  The instructions should be
right there on the screen: "Click here to do such-and-such".  You should NEVER
have to go to a technical support web page to find out how to do certain fairly
basic things.  Whatever CAN be done on Mozilla should be available and explained
well on the main Mozilla screens.

On the positive side, Mozilla does offer smiley faces!  I am not saying in a
mocking way. I LOVE this feature, and wish it could be expanded with even more
expressive graphics!
Now, if only Outlook Express were a bit more secure, and if it offered smiley
faces, ... there would never be any reason to consider abandoning it! At least
not until Mozilla grows up a bit.  

To the makers of Mozilla, I would like to say:  Forget about adding highly
technical stuff that only few people need anyway.  Instead, concentrate on
providing THE BASICS (Contact Groups, multiple signatures, etc., as listed
above) and making the product EASY to use, USER FRIENDLY, and EASY TO CUSTOMIZE
 (See some of the missing preferences listed above).   Make things VISIBLE (not
hidden under multiple menus).  Make every feature accessible with no more than 2
or 3 clicks (preferably just one click).

IF I am mistaken about any of the above. If there is a SIMPLE solution (without
involving running third party software or editing the PREFS file), then please
let me know.

Thanks for listening. And please do something about it.  I am really rooting for
Mozilla. I really wish to use it.  But without the features listed above, I
really can't jump into it. I don't have time for workarounds and fixits or
thrid-party software.  And I can't live without being able to import all my
Contact Groups, and then move them around my several computers.  (I can easily
do this with my WAB file.)

If Mozilla is not made SIMPLE, it will never be accepted by the masses. Please
pass this on to the decision makers at Mozilla.
 
Emilio Trampuz
Emilio2000@Earthlink.net

Reproducible: Always
Steps to Reproduce:
1. Overall usability should be enhanced.
2. Mozilla should be made simple to use.
3. Basic features need to be added (as explained above.

Actual Results:  
Too many basic features are missing (as explained under "Details" above). Some
things are totally missing. Other features rely too much on Plugins, third party
software, and editing the PREFS file, ... and some features are unnecessarily
hidden under multiple menus. 

Expected Results:  
I would hope someone will make Mozilla trully user-friendly, easy to use, and no
 features hidden under multiple menus. 
But I can already see that his is not going to happen. This form was designed to
focus on tiny technical details instead of on the big pitcture of OVERALL
USABILITY.  So, chances are this message will never be seen by those that should
see it.

I wish you all the best. I would REALLY like to use Mozilla. But, it has to be
more usable than it is right now. I simply cannot live without some of the
features described above  (Multiple signatures, ... easily importable and
transportable Contact Groups, ... simpler way to add links, ... more accessible
CC and BCC fields, ... etc.)

Comment 1

14 years ago
Resolving as dup of the bug described in the summary field here.

Reporter: Please read the bug-reporting guidelines and only file one issue per
bug-report:
http://www.mozilla.org/quality/bug-writing-guidelines.html
Also please search bugzilla for duplicates before submitting new reports.

*** This bug has been marked as a duplicate of 111019 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.