Closed Bug 249995 Opened 16 years ago Closed 14 years ago

Select doesn't select the proper option when style "width: 150px" is set

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: maartsen, Unassigned)

References

Details

(Keywords: testcase, Whiteboard: [reflow-refactor])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

When you try to select (by typing the first letter) a country from a selection
(<select>) the selection doesn't  jump to the selected country.

Reproducible: Always
Steps to Reproduce:
1. Open the selection
2. Key in "N"
3. Namibia is selected in the top.
4. The selection doesn't jump to Namibia.

Actual Results:  
Namibia is selected in the top.
The selection doesn't jump to Namibia.

Expected Results:  
The selection should select Namibia.
Attached file Test case for the bug
Attached file Bigger test case
With this testcase the reproduce steps can be followed
Attachment #152411 - Attachment is obsolete: true
I can reproduce the problem on the first testcase (though not on the second one).

Roc, Neil, any idea what's up?
OS: Windows 2000 → All
Hardware: PC → All
Using mouse to open the list, both testcases select in Mozilla/5.0 (X11; U;
Linux i586; en-US; rv:1.7) Gecko/20040708 (Mandrake 10.1). The first does not
automatically scroll to show the selection, while the second does.

Using only keyboard, both select and show selected, though neither expand the
list with the down arrow.
The second test case works perfectly for me.
The first test looks very flickery to me, as if the popup hides and shows.
I can see the problem on both tescases.
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.3) Gecko/20041007
Firefox/0.10

Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Uri, note that you are using a _very_ old Gecko build (6 months old at this
point).  Please test layout bugs in current trunk builds...
I'm seeing the same behaviour with:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041008
Firefox/0.9.1+
*** Bug 259755 has been marked as a duplicate of this bug. ***
(In reply to comment #5)
> The second test case works perfectly for me.
> The first test looks very flickery to me, as if the popup hides and shows.

[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20051216 SeaMonkey/1.5a] (nightly) (W98SE)

Confirming:

The first (obsoleted) testcase needs to use the keyboard twice to see the end of the list: you can use the 'End' key instead of 'N' to get the same (bad) behaviour.
The focus is moved to the selected option (you could check by scrolling the list with the mouse), but then the list flickers:
the scrollbar moves briefly to its end _then goes back to the top_ :-/

If fact, the issue is worse yet:
once the last item item is selected (whether displayed or not), using the up arrow (etc) shows the same bad behaviour...

PS: I got the second testcase to show this bug two separate times ... I think that was when I loaded the first testcase in a new tab while the second was still loading in a new tab two. (I'm not too sure exactly how, but it's worth mentionning, just in case.)

Explaining/Fixing the first testcase would be fine.
Attachment #152411 - Attachment is obsolete: false
Whiteboard: [reflow-refactor]
Still experiencing this issue with FireFox 2.0 (Gecko 20061010)
Still experiencing this issue with FireFox 2.0 (Gecko 20061010)
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061208 Minefield/3.0a1 ID:2006120812 [cairo]

seems fixed by reflow branch landing
Status: NEW → RESOLVED
Closed: 14 years ago
Depends on: reflow-refactor
Resolution: --- → FIXED
Wonder how we can test this...
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.