All users were logged out of Bugzilla on October 13th, 2018

Wrong cursor position in INPUT tag of type text

RESOLVED DUPLICATE of bug 250010

Status

()

RESOLVED DUPLICATE of bug 250010
15 years ago
13 years ago

People

(Reporter: java, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

When the following HTML code is entered for an INPUT tag:

<input type="text" align="right">

The alignment is done correctly but when the user begins to erase the characters
using the backspace key. The cursor moves to another position. It should stay on
the right all the time. This appears when the user enter a text that is longer
than the visual size of the INPUT tag.

Reproducible: Always
Steps to Reproduce:
1. Insert <input type="text" align="right"> in the HTML page.
2. Input some chars into the input field. A sufficient number of chars to hide
the beginning of the entered text.
3. Erase the text using the backspace key.
4. See where the cursor is now.

Actual Results:  
The cursor has moved. It is not on the right anymore as it should be.

Expected Results:  
The cursor must stay on the right all the time.
(Reporter)

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 250010 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
--> Websites :: www.mozilla.com so timeless can close out Firefox :: Product Site.
Component: Product Site → www.mozilla.com
Product: Firefox → Websites
-> Firefox::General (939393)
Component: www.mozilla.com → General
Product: Websites → Firefox
You need to log in before you can comment on or make changes to this bug.