All users were logged out of Bugzilla on October 13th, 2018

When viewing source, cursor no longer is in the source text. You have to mouse click in the window to place it there. Previous versions automatically put the cursor in the right place.

RESOLVED DUPLICATE of bug 203117

Status

--
minor
RESOLVED DUPLICATE of bug 203117
15 years ago
8 years ago

People

(Reporter: antispam, Assigned: doronr)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040616

When you choose view source (CTRL+U) either for a Web page, or an e-mail
message, the text is no longer in focus. Which means if you want to select the
source text, you first have to manually click the cursor into the view source
window before you can select it. This is an extra and unnecessary step which
slows down editing work, and e-mail spam submissions quite a bit. Since the view
source window has no other "focus" in terms of its interface, why not
automatically keep the focus in the display field? This is how Mozilla worked
before the 1.7 (and later) versions.

Reproducible: Always
Steps to Reproduce:
1. Choose and e-mail message or Web page. Any.
2. Either choose View: Source from the menu, or CTRL+U
3. Try to select the text. You can't. You first have to click inside the window
(even though there is NO other focus for the curson to be in) before you can
select the text, or begin scrolling.

Actual Results:  
Unable to scroll through or select text in view source until after clicking the
curson in the display window.

Expected Results:  
Software should automatically place the cursor in the display window so you can
scroll and/or select text right away without having to take the extra step of
clicking the cursor into the display window.

This behavior began to appear in Mozilla v 1.7

Comment 1

15 years ago
dup of bug 227978 / bug 229070?

Comment 2

15 years ago
*** Bug 250665 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
There's an older dupe for this, CC'ing Boris who I believe opened it...

Comment 4

15 years ago
I guess you mean bug 203117.

pi

Comment 5

15 years ago
That's the one.

For what it's worth, this WFM with
  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a2) Gecko/20040710

*** This bug has been marked as a duplicate of 203117 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Updated

8 years ago
Component: View Source → View Source
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.