Error - Inaccessible file/directory not handled

VERIFIED WORKSFORME

Status

()

Core
Networking: FTP
P3
normal
VERIFIED WORKSFORME
18 years ago
16 years ago

People

(Reporter: Jerry Baker, Assigned: dougt)

Tracking

({testcase})

Trunk
x86
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
TO REPRODUCE:
Use Mozilla to go to ftp://ftp.netscape.com and navigate your way down to the 
directory for 4.72. Click on the twisty to list the contents of that 
directory.

WHAT HAPPENS:
Mozilla will display the spinning twisty forever. You can't stop it because the 
stop button is not enabled during FTP operations (bug 20011).

EXPECTED:
It should throw an error since there is no anonymous permission for this dir.

BUILD:
2000012415

Comment 1

18 years ago
Jud, is this some kind of Necko weirdness?
Assignee: don → valeski
Component: XPApps → Browser-General

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M15

Comment 2

18 years ago
Moving to M16.
Target Milestone: M15 → M16

Comment 3

18 years ago
changing qa contact to jrgm@netscape.com on some random bugs
QA Contact: paulmac → jrgm

Comment 4

18 years ago
I am not able to reproduce the infinate twisty. if we hit a dir that we can't
LS, we display an empty dir. We do need to handle permission issues. dialog
throwing is probably the answer. I'm moving this to a feature request.
Summary: Inaccessible file/directory not handled?? → [RFE] Inaccessible file/directory not handled??
Target Milestone: M16 → M20

Comment 5

18 years ago
*** Bug 26365 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
See bug 37367. For what it's worth, i don't like this one tagged as RFE.
Error-handling routines and user feedback is pretty basic stuff, as valeski
writes. 

A shared popup could be used for cases where moz don't find a dir, file or
read-access. But it definately needs to conclude such an error is found and
alert user. The sooner the better ;) Fingertrouble is common and "forever
spinning things" a nuisance: User has no idea whether it's a slow connection or
moz is off to Neverneverland.

Comment 7

18 years ago
*** Bug 37367 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
*** Bug 57895 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
Sorry: 57895 is dup of 18007, not of this one.

Comment 10

17 years ago
*** Bug 60017 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
-> dougt
Assignee: valeski → dougt
Status: ASSIGNED → NEW
(Assignee)

Comment 12

17 years ago
I dont think that this is really an RFE either.  
Blocks: 62352
Summary: [RFE] Inaccessible file/directory not handled?? → Inaccessible file/directory not handled

Comment 13

17 years ago
*** Bug 64744 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 14

17 years ago
This works for me with today's build.  Making as such.  If this still does not
work for you, please reopen.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 15

16 years ago
VERIFIED: WFM, allplats mozilla 095.
-> ftp
+testcase

I'll look into the access/permission problem as well.
Status: RESOLVED → VERIFIED
Component: Browser-General → Networking: FTP
Keywords: testcase
Summary: Inaccessible file/directory not handled → Error - Inaccessible file/directory not handled
(Reporter)

Comment 16

16 years ago
Mass removing self from CC list.
(Reporter)

Comment 17

16 years ago
Now I feel sumb because I have to add back. Sorry for the spam.
You need to log in before you can comment on or make changes to this bug.