NSMacInstaller (and MozMacInstaller) quits when extracting files

VERIFIED FIXED in M14

Status

SeaMonkey
Installer
P1
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Grace Bush, Assigned: Samir Gehani)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Steps to reproduce:

1.Download installer from 
ftp://sweetlou/products/client/seamonkey/macos/8.x/ppc/2000-01-25-08-M14/NSMacIn
staller-M14.sea.bin
2. Enter data in install UI
Actual results: Download completes, extracting files progress starts to show and 
then installer quits.  (same for MozMacInstaller)

Expected results: Seamonkey installed
(Assignee)

Comment 1

18 years ago
Investigating to see if ssu's libjar fix worked for the Mac too.
Status: NEW → ASSIGNED
Priority: P3 → P1
Target Milestone: M14

Comment 2

18 years ago
is this a blocker?
(Reporter)

Comment 3

18 years ago
I used  the netscape....bin file which unstuffed and launched ok
(Assignee)

Comment 4

18 years ago
No, I don't think this is a blocker since as Grace points out we have the 
netscape5-mac-M14.sea.bin file and its mozilla equivalent for QA to install 
from.

Comment 5

18 years ago
just fyi, we had a crash while running RegXPCOM this morning, as part of the 
packaging process. After killing the task, the automation automatically resumed 
but I noticed in the log that one of the ftp session timed out... meaning that 
one of the uploads probably failed.
Let's hope for a better result tomorrow.
(Assignee)

Comment 6

18 years ago
FYI, I'm still building the tip and may only get to this tomorrow. So, due to 
nsIFile changes this may still be broken tomorrow. 
(Assignee)

Comment 7

18 years ago
The XPInstall engine appears broken on the Mac. This bug had to do with the 
installer, not the engine, hence closing. I've opened bug 25288. In the future, 
please don't reopen this bug. Open a new one since we are usually dealing iwth 
*different* problems when we see installer failure during extraction. 
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

18 years ago
.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.