'file could not be saved because an unknown error occurred. Sorry about that ' while saving a file

RESOLVED WORKSFORME

Status

()

Firefox
File Handling
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: uamjet602, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

Our intranet application allows one to download files. When doing that using
firefox I get this message:

--- snip ---
<made up filename> could not be saved because an unknown error occurred.

Sorry about that. Try saving to a different location.
--- snip ---
The filename in my case is:
"c:\docume~1\userna~1\locals~1\temp\6fquz3o0-9999.doc" with my real username
instead of userna~1.

Reproducible: Always
Steps to Reproduce:
1. Download a file using our intranet application :) I will include headers
captured using the 'Live HTTP headers' extension.

Actual Results:  
I got an error dialog.

Expected Results:  
The file should have been saved.

This could be connected to the fact that the server is using https, so perhaps
the file is not saved because of some 'don't save secure pages' policy or something.

I can readily imagine something being wrong with the headers the server is
sending; Please let me know what it should send so I can fix it. Obviously these
headers work for internet explorer.

The error message makes no sense though, especially the stupid 'Sorry about
that' apology and the suggestion to save it somewhere else when I wasn't even
offered a chance to save it somewhere. I also do not understand where the file
name in the dialog comes from.
(Reporter)

Comment 1

14 years ago
Created attachment 152506 [details]
Headers captured using 'Live HTTP headers'

slightly edited to remove authentication etc.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050613
Firefox/1.0+ ID:2005061301

WFM

have you tried in Firefox -safemode

why does this unco bug have status NEW ?
(Reporter)

Comment 3

13 years ago
Apparently either this got fixed or our application changed; I cannot reproduce
it anymore.

The bug is NEW because I have the canconfirm permission, so all my bugs are NEW
automatically. It might be that there is a way to turn that off now, but there
was none when I filed the bug.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Resolved WFM, because no specific Fix or Bugzilla ID was namend for this.
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.