Closed Bug 250236 Opened 16 years ago Closed 15 years ago

Opening bookmark group in tabs uses existing tab

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 216346

People

(Reporter: davidmichaelkarr, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

In Netscape, when I "Open" a bookmark group, it creates new tabs for all the
items in the group.

In Firefox, when I "Open in tabs" a bookmark group, it "takes over" my currently
visible tab for the first of the N bookmarks in the group. This should work the
same as it does in Netscape, creating new tabs for all of the bookmarks in the
group.

Reproducible: Always
Steps to Reproduce:
1. Open the browser and go to a URL.
2. Configure browser to show tabs even if only one is present.
3. Create a new bookmarks folder and add two or more bookmarks to it.
4. Right-click on the new folder and select "Open in tabs".

Actual Results:  
The original single tab has now been reused for one of the bookmarks in the group.

Expected Results:  
The original single tab should have been left alone, creating new tabs for all
the bookmarks in the group.
This is by design.  To change it, go to about:config and set
browser.tabs.loadFolderAndReplace to false.
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → INVALID
*** Bug 250240 has been marked as a duplicate of this bug. ***
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 216346 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.