Closed Bug 250242 Opened 18 years ago Closed 18 years ago

when opening new tabs quickly, focus remains in form elements of previous tabs

Categories

(Firefox :: Tabbed Browser, defect)

x86
Linux
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 245502

People

(Reporter: itrebax, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

If a tab with a form element that automatically has the focus is opened followed
by another tab, the text that should go into the url of the new tab goes into
the focused form element of the previous tab.  It seems to only happen when the
browser is loaded for the first time, and not subsequent times.

Reproducible: Sometimes
Steps to Reproduce:
1. open a new firefox window
2. open a website that has a form element with focus on loading the page
(google.com among others)
3. quickly open a new tab and try to type something

Actual Results:  
Characters that should go into the address bar are placed into the form element
from the previous tab.  Sometimes a few characters go into the address bar first
and then subsequent characters into the form element from the previous tab.

Expected Results:  
Place all characters in the address bar of the new tab.

I am currently using Firefox 0.8 on linux, but the problem also occurs on 0.9 on
windows.

*** This bug has been marked as a duplicate of 245502 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.