Scrolling keys should scroll when Find Toolbar has focus

RESOLVED FIXED

Status

()

Toolkit
Find Toolbar
--
enhancement
RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

({regression})

unspecified
regression
Points:
---
Bug Flags:
blocking-aviary1.0PR -
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [patch doesn't work with frames])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
The following keys scrolled the page with the old find-as-you-type.  They should
scroll the page when the Find Toolbar has focus.

    Down, Up (except on Mac?)
    Pgdn, Pgup (all platforms)

Home, End, Space, and Shift+Space should do their normal text-editing things,
though.

Making these keys scroll would conflict with adding autocomplete to the Find
Toolbar, but I don't think the Find Toolbar should have autocomplete.
-> Find Toolbar component.
Component: General → Find Toolbar / FastFind

Comment 2

14 years ago
This is a major regression in find-as-you-type usability. 90% of the time after
I find the string I'm looking for, I want to scroll up and down to see the context.
Flags: blocking-aviary1.0PR?
Keywords: regression
OS: Windows XP → All
Hardware: PC → All

Comment 3

14 years ago
Created attachment 154928 [details] [diff] [review]
patch to fix

This patch allows the PageUp/Down and Up/Down arrows to scroll the page while
the findbar has focus.

This patch also fixes an unreported bug where the highlight is not working into
frames.

Comment 4

14 years ago
Comment on attachment 154928 [details] [diff] [review]
patch to fix

request review
Attachment #154928 - Flags: review?(firefox)
please fix your indentation... the lines starting with "evt." are overly
indented (please turn OFF tabs in your editor when editing mozilla code!)
Flags: blocking-aviary1.0PR?
Flags: blocking-aviary1.0PR-
Flags: blocking-aviary1.0+

Comment 6

14 years ago
Created attachment 155037 [details] [diff] [review]
patch v2

Same patch with tabs removed to correct comments by Ben.
Attachment #154928 - Attachment is obsolete: true

Updated

14 years ago
Attachment #154928 - Flags: review?(firefox)

Updated

14 years ago
Attachment #155037 - Flags: review?(firefox)

Updated

14 years ago
Blocks: 254195

Updated

14 years ago
Whiteboard: [have patch]

Updated

14 years ago
Whiteboard: [have patch] → [patch needs reworking]

Comment 7

14 years ago
Comment on attachment 155037 [details] [diff] [review]
patch v2

I don't think this patch is good enough--what if the phrase is found in a
frame? Will this scroll the frame?
Attachment #155037 - Flags: review?(firefox) → review-

Comment 8

14 years ago
This is not a 1.0 blocker. It's an RFE; this didn't work in the old find dialog
either.
Flags: blocking-aviary1.0+ → blocking-aviary1.0-
(Reporter)

Comment 9

14 years ago
True, but it's annoying because I keep forgetting to close the Find Toolbar
after using it.

Comment 10

14 years ago
> It's an RFE; this didn't work in the old find dialog either.

Scrolling did work fine, however, with the old Find-As-You-Type. (See comment
2). Ben had plused this; Renominating since the minusing comment doesn't seem to
address the regression vs. FAYT.
Flags: blocking-aviary1.0- → blocking-aviary1.0?

Comment 11

14 years ago
As far as I can tell, scrolling up and down with the arrow keys works fine now
with FAYT ever since I fixed it to not actually focus the toolbar when using FAYT.

I'm starting to change my mind and think that getting this fix in is better than
nothing. Right now scrolling won't work on either framesets or normal pages.
Seems like a big improvement to just get it working on normal pages, at least,
especially given how uncommon framed pages are becoming.

Comment 12

14 years ago
Okay, I went ahead and fixed this in the non-framed case. I believe that's
enough for 1.0.
Flags: blocking-aviary1.0? → blocking-aviary1.0-
Whiteboard: [patch needs reworking] → [patch doesn't work with frames]
Assignee: firefox → nobody
QA Contact: general → fast.find
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050621
Firefox/1.0+ ID:2005062110

with the new FAYT bar you can scroll as you wish
->INVALID ?
Yes. Currently find toolbar doesn't have this problem.

-> FIXED
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.