If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Lose Focus after using "back"

VERIFIED DUPLICATE of bug 36539

Status

()

Firefox
Disability Access
VERIFIED DUPLICATE of bug 36539
14 years ago
13 years ago

People

(Reporter: Shantanu Oak, Assigned: Aaron Leventhal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

In IE I click on a link and read the page. I use Alt + back to go back. Then use
Tab to move to the next link. and hit enter. In firefox, if I use tab after
using the Alt + back arrow, the first link on the page is selected.
When I use back, it still does remember the position of the page but forgets the
link that was selected! Using tab after Alt + Back arrow is so convenient. If
the focus after using Alt Back is at the text from where I left shouldn't the
links behave in the same way? 

Reproducible: Always
Steps to Reproduce:
1. Click on any link on a page
2. Use Back to go the previous page
3. Use Tab
Actual Results:  
You will find that you have selected the first link on the page.

Expected Results:  
The next link

Comment 1

14 years ago
Related bug 79443.
Summary: Loose Focus after using "back" → Loose Focus after using "back"

Comment 2

13 years ago
Loosing the focus on a link is indeed annoying, especially when using the
keyboard to look through a list of search results (a rather frequent use case, I
would have assumed).

Comment 3

13 years ago
I have the same problem. Am running Firefox 0.9.2 and earlier 0.8 and Windows
XP. Same deal with both versions. Really annoying for a keyboard navigator like
myself.
Assignee: firefox → aaronleventhal
Component: General → Accessibility
QA Contact: firefox.general → bugzilla

Comment 4

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040921
Firefox/0.10

Occurs here too
(Assignee)

Comment 5

13 years ago

*** This bug has been marked as a duplicate of 36539 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Summary: Loose Focus after using "back" → Lose Focus after using "back"
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.