Ameritrade Streamer works in Mozilla, hangs in Firefox!

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
14 years ago
6 years ago

People

(Reporter: Deven Corzine, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
I'm sorry, I don't know how to reproduce this problem for anyone without an
Ameritrade account, since I don't understand what the problem is.

Using a PC under Windows 2000, I can login to Ameritrade and use the Streamer
Java application from Mozilla 1.6 just fine.  However, if I attempt to use the
same application from Firefox 0.9.1, it hangs with "Loading Java Applet ..." in
the status bar and a Java logo in the applet area.  It doesn't appear to be slow
-- it appears to hang completely.  Using Mozilla, the applet displays within a
minute or less, but under Firefox, I've let it sit there for over an hour with
no progress.

What's different about Firefox that it's broken there, but works fine in Mozilla?

Comment 1

14 years ago
Yes It does this in versioin 9.2 As well. It just hangs at Loading Applet. I
have found that If I reboot my system the Applet loads one time after I reboot,
but if I close it then I have to reboot inorder for the applet to reboot.

Comment 2

13 years ago
I have this problem also. (Windows XP) This is the Javascript console message:

Error: console has no properties
Source File: https://wwws.ameritrade.com/cgi-bin/apps/StreamerCheck
Line: 28

Comment 3

13 years ago
All Java popups from Ameritrade cause firefox to hang and no longer function as
a web browser. Additional tabs also hang forever. The Java popups do come up and
work though. For IE there is no problem the first time launching these. However,
the second time is different. These same popups take significantly longer to
bring up after leaving ameritrade, coming back, and relaunching them. For IE,
this problem is not there if Java is shut down completely (by closing IE). This
seems like bad Java code by ameritrade or Sun, but IE can recover and firefox
cannot. If the firefox browser is closed after hanging like this, it throws an
exception.

If you need any additional information I can give it to you. I will open the
java console to see what is going on. I would suggest changing the severity
level because of the complete crash of Firefox. This fails in Firefox 1.0 for me. 
Assignee: bross2 → nobody

Comment 4

8 years ago
Is this still an issue?
Given the miniscule odds that Ameritrade would still be using a Java applet in 2012, I'll bet on "no".
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.