Image elements aren't tab-stopped and don't show focus.

VERIFIED FIXED in mozilla1.0

Status

()

Core
HTML: Form Submission
P2
enhancement
VERIFIED FIXED
20 years ago
17 years ago

People

(Reporter: Paul MacQuiddy, Assigned: Marc Attinasi)

Tracking

({access})

Trunk
mozilla1.0
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-], URL)

Attachments

(2 attachments)

(Reporter)

Description

20 years ago
Form elements of type "image" need to be tab stopped & they need to have the
cursor changed to a hand when the mouse is over them. The "bug/feature" is that
we're not treating input form elements uniquely. This creates an inconsistent
feel when web browsing.

For instance, go to the bugsplat login page. It's non-intuitive (web-wise) to
click on something when there's not a hand there. IE supports this.

Other similar sites would be the e*trade login site and Netcenter's webmail
login page.

Updated

20 years ago
Status: NEW → ASSIGNED
Summary: Form elements don't look like links to the user. → Image elements don't change cursor on mouseover, tab-stop.
(Reporter)

Comment 1

20 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser

Updated

20 years ago
QA Contact: 4110 → 4137

Comment 2

20 years ago
Reassigning qa contact to cpratt@netscape.com
(Reporter)

Comment 3

20 years ago
Eric, can you set a Target Milestone for this one?

Updated

20 years ago
Target Milestone: M6

Comment 4

20 years ago
Guessing I won't get this in for M5

Comment 5

20 years ago
*** Bug 4586 has been marked as a duplicate of this bug. ***

Comment 6

20 years ago
Per bug 4586, another test URL is: http://schist/musicblvd.html

Comment 7

20 years ago
Oh well, I was wrong.
Just checked in a fix.

Updated

19 years ago
Assignee: pollmann → joki
Status: ASSIGNED → NEW
Summary: Image elements don't change cursor on mouseover, tab-stop. → Image elements aren't tab-stopped.

Comment 8

19 years ago
The cursor changes now, so the only remaining issue is that image inputs are
simply not tab-stopped.  Tom, can you take this?

Comment 9

19 years ago
Moving out to M7

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M7 → M8

Comment 10

19 years ago
Bonus if I still get to this for M7 but I probably won't.

Updated

19 years ago
Target Milestone: M8 → M9

Comment 11

19 years ago
Don't need to be holding M8 with this.

Updated

19 years ago
Target Milestone: M9 → M12

Comment 12

19 years ago
Moving down list

Updated

19 years ago
Target Milestone: M12 → M14

Comment 13

19 years ago
move to M14 (post-beta)

Comment 14

19 years ago
QA Contact update.
Target Milestone: M14 → M17
Moving M17.

Comment 16

18 years ago
Taking a look at this it seems to be very close to working now.  Focus already 
shifts to the image element, though its not visible currently.  I have a small 
fix to make events trigger the image button.
Keywords: nsbeta3
Whiteboard: [fixinhand]

Comment 17

18 years ago
Updating Milestone to M18.
Target Milestone: M17 → M18

Comment 18

18 years ago
Marking nsbeta3+...
Whiteboard: [fixinhand] → [fixinhand][nsbeta3+]

Comment 19

18 years ago
This bug isn't completely fixed after the landing of joki's fixes.  We can't 
spend more time on this pre Netscape 6 ship.

This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration, but do not clear 
the nsbeta3- nomination.
Whiteboard: [fixinhand][nsbeta3+] → [nsbeta3-]
Target Milestone: M18 → Future

Comment 20

18 years ago
Updating QA contact.
QA Contact: ckritzer → vladimire

Comment 21

18 years ago
This bug seems to be fixed except for one cosmetical thing: Indication of focus 
on <input type=image>. Need to have some kind of a border to show around the 
image when you tab to it. 

Comment 22

18 years ago
I can fix this on my PC, although I don't know how to provide a patch.

There is a block in html.css:

:link:focus, :visited:focus {
  -moz-outline: 1px dotted WindowText;
}

Just add input[type="image"]:focus to the list.

In passing, I noticed this block:

img[usemap], object[usemap] {
  color: blue;
  -moz-user-focus: normal;
}

You might want an outline for img[usemap]:focus and object[usemap]:focus i.e.

:link:focus, :visited:focus,
img[usemap]:focus, object[usemap]:focus,
input[type="image"]:focus {
  -moz-outline: 1px dotted WindowText;
}
Marc, can you look at the fix to html.css and check it in if this is correct and
it still works?
Assignee: joki → attinasi
Status: ASSIGNED → NEW
Keywords: access
Target Milestone: Future → ---
(Assignee)

Comment 24

18 years ago
The form elements are now styled by rules in forms.css, not html.css. I added
the following rule to forms.css and it works fine:

input[type="image"]:focus {
  -moz-outline: 1px dotted WindowText;
}

CC'ing RodS since this is his thang. Rod, can you review the change to forms.css?
Status: NEW → ASSIGNED
Summary: Image elements aren't tab-stopped. → Image elements aren't tab-stopped and don't show focus.
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 25

18 years ago
Created attachment 21599 [details] [diff] [review]
patch to forms.css
(Assignee)

Comment 26

18 years ago
Created attachment 21600 [details]
simple testcase

Comment 27

18 years ago
Looks good to me r=rods
[note that the WindowText is there because we currently have a bug whereby 
the equivalent of -moz-outline-color is not taking the colour from the 'color'
property correctly. This is similar to the border-color bug. Once that is fixed
we should remove the colours in all our -moz-outline declarations.]

Comment 29

18 years ago
sr=buster
(Assignee)

Comment 30

18 years ago
Fixed: rule added to forms.css
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 31

18 years ago
I still dont see any indication of the INPUT type="Image" being selected on 
Windows 98 build 2001-01-31-14-MTEST
Reopening
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 32

18 years ago
There are unfortunately two bugs (don't know their numbers sorry) that may relate.
1. -moz-outline doesn't work on images at all well anyway (try mozilla logo!).
2. forms.css overrides quirks.css so the standard 2px blue border doesn't appear.
(Assignee)

Comment 33

18 years ago
I just verified this working. Please check the testcase attached, and if other
sites / test do not work please attach and reopen.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 34

18 years ago
Verifying on 
Windows 98 build 2001-02-06-04-Mtrunk
Liunux RedHat build 2001-02-06-08-Mtrunk
Mac OS8.x build 2001-02-06-08-Mtrunk

Status: RESOLVED → VERIFIED

Comment 35

17 years ago
This will need to be readdressed when bug 72703 is fixed.
You need to log in before you can comment on or make changes to this bug.