[regression]Can't do queries based on date of comments anymore

VERIFIED FIXED in Bugzilla old

Status

()

Bugzilla
Bugzilla-General
P2
major
VERIFIED FIXED
18 years ago
5 years ago

People

(Reporter: Pierre Saslawsky, Assigned: Terry Weissman)

Tracking

unspecified
Bugzilla old

Details

(Reporter)

Description

18 years ago
I used to make Bugzilla queries based on the date of comments that I made on bug 
reports, looking for strings like the one below in the description field:

     "Additional Comments From pierre@netscape.com  2000-01-1"

It doesn't work anymore. I think it was broken in the past few days. It's a bit 
annoying, I used to fill out my weekly status reports using that method.

Maybe the problem is related to the "Added comment" checkbox in the Query page. I 
don't remember having seen it before. Another solution would be to have this 
checkbox followed by a text field allowing you to enter a number of days (ie. <
username> added comments in the last <xx> days).
(Assignee)

Comment 1

18 years ago
Sigh.

So, the good news is that those dates are now really stored in the database.  It
should be possible to do real queries based on those dates (like, "find all bugs
that I added a comment to between 1/15/2000 and 1/25/2000").

The bad news is that there is no UI to do those queries.  The new "Added
comment" thing you noticed does match against the name, but there is no place to
match against the date.  I guess I can add something to that ugly scrolling list
(the one that says "where the field(s)").
Status: NEW → ASSIGNED
Priority: P3 → P2
(Reporter)

Comment 2

18 years ago
That would be neat. Thanks.

I tried with the current page to use the "Added comment" checkbox in addition to 
the "Changed in the last X days" field but it returned me a long list including 
many bugs that I added comments to several months ago and that were touched by 
someone else in the last X days. Make sure we don't have the same results with 
the new system.
(Assignee)

Comment 3

18 years ago
You can now search for "Comment" "changed before" and "Comment" "changed after"
using the new boolean chart feature.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

18 years ago
Reopening: it doesn't work for me. I tried "Comment changed by 
pierre@netscape.com" AND "Comment changed after 2000-01-25" but it returns a long 
list of bugs that don't match the criteria (bug 1516 for instance).

I tried with different date formats ("2000-01-25", "2000-01-25 00:00:00", "2000-
01-25 00:00:00 PST" etc...) but it didn't work.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 5

18 years ago
Whoops!  I had a stupid typo.  Fixed.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
per Terry, auto-verifying any resolved bug that hasn't been touched since before 
2.10 was released.
Status: RESOLVED → VERIFIED
Moving to Bugzilla product
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
QA Contact: matty
Target Milestone: --- → Bugzilla old
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.