Firefox rename files with underscore in their name truncating them.

VERIFIED DUPLICATE of bug 252309

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 252309
14 years ago
13 years ago

People

(Reporter: Jay Master, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.7) Gecko/20040614 Firefox/0.9

In Yahoo Mail when I got mail with attachments named with some underscore "_"
and I save them to my hard disk Firefox rename them truncating the name at the
first part. E.g: a file named "simple_example.pps" will be renamed into "simple"
(without extension).
Anyway some kind of files keeps the extension (for example zip file:
"simple_example.zip" will be renamed into "simple.zip").

Maybe those files are named with a space instead of underscore (and Yahoo shows
"_") because Internet Explorer save them replacing underscores with spaces.


Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Actual Results:  
incorrect file name

Comment 1

14 years ago
I can confirm that this happens with both my Windows executable download version
of firefox (which incorrectly calls itself firefox 0.8, even though it is 0.9.1)
and my linux debug build of firefox, which correctly calls itself 'Mozilla/5.0
(X11; U; Linux i686; en-US; rv:1.8a2) Gecko/20040709 Firefox/0.9.0+'.

On both versions, when I save a file with an underscore in the filename, the
file is saved as a substring of the filename. I.e. I saved the file
'All_logos.gif' as 'All'. 

Now, I have an old version of Mozilla Firebird for windows (Gecko/20031007
Firebird/0.7) And it took the same image and saved it as 'All.gif'.

Also on Windows, I have Mozilla 1.6 (Gecko/20040113). This also wanted to save
it as 'All', however mozilla gives a save dailog, and the type it was going to
save 'All' as was *.gif.

I have noticed this behaviour with several file types.


Comment 2

13 years ago
This behavior still exists in 1.0 preview release of Firefox (saves file with an
underscore in the name WITHOUT the extension) as well as Mozilla 1.7.2 (saves
the file with the name truncated at the underscore but WITH the proper
extention). This is under linux.

Comment 3

13 years ago
Created attachment 160386 [details]
empty file with underscore to attempt to download + save

Updated

13 years ago
Attachment #160386 - Attachment is obsolete: true

Comment 4

13 years ago
I can confirm this bug. I have similar problems on Yahoo! Mail on every build of
Firefox I've ever tried. My word documents such as (my_example.doc) get renamed
to my (without extension). Also of note is that if I try to download this file
in IE, it will just replace the underscores with spaces (my example.doc).

Comment 5

13 years ago
Move your votes/CCs to this bug.

*** This bug has been marked as a duplicate of 252309 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.