If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox won't display the height attribute correctly

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Sverre Palmström, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.8

OK.
I don't know if this is the place for submiting this bug, but here it goes anyway.
For some reason FireFox won't diplay the height attribute when i either assign a
style="height: 100%" or class="fullscreen" which contains height: 100%;
I've talked to a few friends of mine and one of them was using Safari which
displayed it correctly. I tried it on IE too, but with no luck. As far as I know
 putting CSS inside the <table> tag gives no faults. When validating the XHTML
code on w3.org it had nothing to complain over.

Hope you guys will be able to sort this out.
Thansk.

Reproducible: Always
Steps to Reproduce:
1. 
2.
3.



Expected Results:  
The table should displayed all over the page width the attributes widht and
height set to 100%

Updated

13 years ago
Assignee: firefox → nobody
Component: General → Layout
Product: Firefox → Browser
QA Contact: firefox.general → core.layout
Version: unspecified → Trunk
> For some reason FireFox won't diplay the height attribute when i either assign
> a style="height: 100%" or class="fullscreen" which contains height: 100%;

The reason is that the page claims to be XHTML, so we render in standards mode.
 And the CSS specification says that a percentage height is treated as "auto" if
the parent has an "auto" height (as the <body> does in this case).

Marking invalid; Mozilla's rendering is correct.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.