If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Graphs not appearing on reports.cgi page

RESOLVED WORKSFORME

Status

()

Bugzilla
Reporting/Charting
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Adam, Assigned: gerv)

Tracking

2.16.5
x86
Windows XP

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: 

I have setup collectstats.pl to run at 12.05am every day, as described in the 
user doc. Have also ensured the appropriate perl modules are installed. But 
there is just no way of producing graphs from the report page on our 
installation. The option just does not appear - I assume there is something 
else I need to do, but can't find it in any of the documentation.

Reproducible: Always
Steps to Reproduce:
1. login
2. Go to the reports.cgi page
3.

Actual Results:  
no option to print graphs

Expected Results:  
showed an option to print graphs
What version of Bugzilla?
(Reporter)

Comment 2

13 years ago
updated with version, sorry!
Version: unspecified → 2.16.5
(Assignee)

Comment 3

13 years ago
Adam: please explain exactly what you click to get to reports.cgi, exactly what
you see, and exactly what you expect to see. Thanks :-)

Gerv
(Reporter)

Comment 4

13 years ago
To get to reports.cgi:
1. Login
2. Click on Reports link at bottom of page

What I see:
Query Kitchen, which includes options for Product, Output and Switches.

What I expect to see:
The Charting kitchen, much like http://bugzilla.mozilla.org/reports.cgi

Am I missing something really simple? The documentation says I only need to 
run collectstats.pl for a couple of days, and the graphs will just start 
working - I read that in the doco at 
http://www.bugzilla.org/docs/2.16/html/extraconfig.html

Thanks very much for your help.
(Assignee)

Comment 5

13 years ago
> Query Kitchen, which includes options for Product, Output and Switches.

I don't know this screen at all.
Do you mean like http://bugzilla.mozilla.org/query.cgi ?

Gerv
(Assignee)

Comment 6

13 years ago
The two screens are the same screen - it got renamed to Charting Kitchen in the
2.17.x series.

However, reports.cgi still thinks you don't have any data to generate your charts.

Is there a file $BUGZILLA_HOME/data/mining/-All-? Does it have charting data in
it? Is it readable by your webserver user?

Gerv
(Reporter)

Comment 7

13 years ago
this is the contents of the file:

# Bugzilla Daily Bug Stats
#
# Do not edit me! This file is generated.
#
# fields: 
DATE|NEW|ASSIGNED|REOPENED|UNCONFIRMED|RESOLVED|VERIFIED|CLOSED|FIXED|INVALID|W
ONTFIX|LATER|REMIND|DUPLICATE|WORKSFORME|MOVED
# Product: -All-
# Created: Wed Jun 23 11:10:12 2004
20040623|48|1|0|0|2|0|1|1|0|2|0|0|0|0|0
20040623|48|1|0|0|2|0|1|1|0|2|0|0|0|0|0
20040623|48|1|0|0|2|0|1|1|0|2|0|0|0|0|0
20040623|48|1|0|0|2|0|1|1|0|2|0|0|0|0|0
20040623|48|1|0|0|2|0|1|1|0|2|0|0|0|0|0
20040624|48|1|0|0|2|0|1|1|0|2|0|0|0|0|0
20040625|90|1|0|0|2|0|1|1|0|2|0|0|0|0|0
20040626|90|1|0|0|2|0|1|1|0|2|0|0|0|0|0
20040627|90|1|0|0|2|0|1|1|0|2|0|0|0|0|0
20040628|103|1|0|0|2|0|1|1|0|2|0|0|0|0|0
20040629|103|1|0|0|2|0|1|1|0|2|0|0|0|0|0
20040704|102|3|0|0|3|0|1|1|1|2|0|0|0|0|0
20040704|102|3|0|0|3|0|1|1|1|2|0|0|0|0|0
20040707|102|3|0|0|3|0|1|1|1|2|0|0|0|0|0
20040707|102|3|0|0|3|0|1|1|1|2|0|0|0|0|0
20040707|102|3|0|0|3|0|1|1|1|2|0|0|0|0|0
20040707|102|3|0|0|3|0|1|1|1|2|0|0|0|0|0
20040707|102|3|0|0|3|0|1|1|1|2|0|0|0|0|0
20040707|102|3|0|0|3|0|1|1|1|2|0|0|0|0|0
20040707|102|3|0|0|3|0|1|1|1|2|0|0|0|0|0
20040707|102|3|0|0|3|0|1|1|1|2|0|0|0|0|0
20040707|102|3|0|0|3|0|1|1|1|2|0|0|0|0|0
20040707|102|3|0|0|3|0|1|1|1|2|0|0|0|0|0
20040707|102|3|0|0|3|0|1|1|1|2|0|0|0|0|0
20040708|102|3|0|0|3|0|1|1|1|2|0|0|0|0|0
20040709|102|3|0|0|3|0|1|1|1|2|0|0|0|0|0
20040710|102|3|0|0|3|0|1|1|1|2|0|0|0|0|0
20040711|102|3|0|0|3|0|1|1|1|2|0|0|0|0|0
20040712|102|3|0|0|3|0|1|1|1|2|0|0|0|0|0

Does this look OK?

It is readable also.

Any ideas? Thanks for your help.
(Assignee)

Comment 8

13 years ago
That looks OK. How are you with Perl? The next step is basically to open up the
reports.cgi file and debug it, working out why it's not offering the charting
option...

Gerv
(Assignee)

Comment 9

13 years ago
Adam: did you manage to resolve this?

Gerv
(Reporter)

Comment 10

13 years ago
Hi Gerv,

Unfortunately not. I have moved to a new hosting provider last week, and will 
try again. I'm at a loss with this one.

Thanks,

Adam.
(Assignee)

Comment 11

13 years ago
Adam: ping? Any change?

Gerv
(Reporter)

Comment 12

13 years ago
Hi, thanks for checking in - no change. I never was able to get it working. 
However we've moved to a new hosting provider now, so I may be able to get it 
working with them.

Thanks again,

Adam.
(Assignee)

Comment 13

12 years ago
Adam: does this work with your new provider?

Gerv

Updated

12 years ago
QA Contact: mattyt-bugzilla → default-qa

Comment 14

11 years ago
2.16 is dead, we got no reply in a year and we don't have dupes of this bug. Marking WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.