No Dialog When .xpi Install Is Prohibited

RESOLVED DUPLICATE of bug 248486

Status

--
enhancement
RESOLVED DUPLICATE of bug 248486
15 years ago
11 years ago

People

(Reporter: duff, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.6.1 StumbleUpon/1.901
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.6.1 StumbleUpon/1.901

When the option of "Allow web sites to install software" is disabled and a web
site tries to install a .xpi file, no warning or notice is given that the
install was prohibited.  This option is available in Options -> Advanced ->
Software Update and is enabled in the default setup. This occurred in Mozilla
Firefox 0.9.1 but probably has the same results in earlier browsers.

Reproducible: Always
Steps to Reproduce:
1. Disable the option "Allow web sites to install software"
2. Open a .xpi file (such as
http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.7.1/shellblock.xpi)

OR

1. Disable the option "Allow web sites to install software"
2. Save a .xpi file to your hard drive
3. Open it with Mozilla Firefox 0.9.1
Actual Results:  
Nothing. No warnings were given that a .xpi file was trying to install.  Even
when a .xpi file is saved to the hard drive, it still refuses to open in Mozilla
Firefox 0.9.1.

Expected Results:  
The browser should display a notice to the user that a .xpi file was prohibited
from installing and present the user with a choice to enable the option  "Allow
web sites to install software."  Otherwise, there is no way of knowing what is
causing the interuption of the install.

Comment 1

15 years ago
Related to Firefox bug 248486?
(Reporter)

Comment 2

15 years ago
(In reply to comment #1)
> Related to Firefox bug 248486?

Yes. I guess I didn't find that while searching. Thanks for pointing that out.  
This bug report should be closed and marked as a duplicated of bug 248486.



*** This bug has been marked as a duplicate of 248486 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Updated

11 years ago
Component: Installer: XPI Packages → Installer
QA Contact: general
You need to log in before you can comment on or make changes to this bug.