temoprary toolbars (tab bar, find bar) should not shift window contents

RESOLVED DUPLICATE of bug 248715

Status

()

Firefox
Tabbed Browser
--
enhancement
RESOLVED DUPLICATE of bug 248715
14 years ago
14 years ago

People

(Reporter: Greg Campbell, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040708 Firefox/0.9.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040708 Firefox/0.9.0+

When a link is opened in a new background tab, or when the find toolbar opens,
the content in the browser window shifts down the distance of the new toolbar.

Since most users focus their gaze somewhere towards the middle of the content
area--not at the very top--it would make more sense to have the new toolbar (in
effect) cover up the top bit of the content area (actually: scrolling the window
the height of the toolbar when the toolbar opens).

Exception: if the content area is showing the very top of the document, just
shift everything down (like the current behavior).

Reproducible: Always
Steps to Reproduce:
1. Scroll somewhere in the middle of a page.
2. Open a new tab in the background or initiate the find toolbar.
Actual Results:  
The content shifts down the window as the toolbar opens, disturbing the
continuity of reading.

Expected Results:  
The content should have remained in a fixed location on the screen, allowing the
user's gaze to remain fixed in one place.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 248715 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.