installer should uninstall older version

VERIFIED DUPLICATE of bug 247884

Status

()

Firefox
Installer
--
enhancement
VERIFIED DUPLICATE of bug 247884
14 years ago
12 years ago

People

(Reporter: Chase Johnson, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

Each time mozilla.org releases a new release, I download and install, but I've
found that if I don't uninstall the older version, I get multiple entries in my
"Add/Remove Programs" dialog in Windows XP.  Not really a problem, but for the
0.9.x releases, choosing to uninstall say 0.9.1 after installing over it with
0.9.2 (in the same directory) uninstalls 0.9.2.  I suggest that the Windows
installer detect whether an existing Firefox (or Thunderbird, as it produces
identical results) install exists and, if found, uninstall the old and install
the new in the same directory.  This would simplify and streamline release upgrades.

Reproducible: Always
Steps to Reproduce:
1. Have old release.
2. Download new release.
3. Double-click and run installer.

Actual Results:  
I have two entries in "Add/Remove Programs" dialog for Firefox (or Thunderbird).
 Trying to get rid of the old entry by unstalling (when both were 0.9.x) would
uninstall new install.

Expected Results:  
Found old install, uninstalled it, and installed new release in same directory,
keeping my extention and theme, if compatible.

Sorry not really a bug, but many non-computer-savvy users may download new
release, install, and then accidentally uninstall trying to get rid of the "old
version" in the "Add/Remove Programs" dialog.

Comment 1

14 years ago
->Enhancement, since the release notes specifically say that at present you must
uninstall old versions before installing new ones.
Severity: minor → enhancement
*** Bug 250890 has been marked as a duplicate of this bug. ***
probably a dupe of bug 247884 

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 247884 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.