When browsing nearly any forum of other webpage, upon hitting the "back" button to return to the main site, Firefox returns me to the top of the first page, rather than leaving the window centered on where it was before.

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: kandnhome, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.8

Suppose I choose to go to the "processors" forum (just as an example -- this
happens on EVERY webpage I've seen, but sometimes it comes and goes) at
PCPerspective.  I have to scroll down a couple screen heigths to get to the link
for the processor forum.  When I'm done reading that forum and want to go back
to the main page with all the forum links, Firefox just displays the very top of
the page instead of going back to the link I just clicked as the top of the
view.  I'd say I spend an extra 15 minutes a day just scrolling back to my last
view.  But otherwise, Kudos! Excellent work!

Reproducible: Always
Steps to Reproduce:
1.Go to a website, scroll down it half way or so
2. click a link to take you deeper into that website
3. click the "back" button.  Whammo, back at the top of the previous page.

Actual Results:  
I was back at the top of the page instead of where I was looking when I clicked
the link that took me forward.

Expected Results:  
when I hit the back button, I expect the browser to go back to exactly where I
was before I went forward. 

The bug occurs no matter which theme I'm using (I've tried 5) nor which version
of Firefox I'm using (it's been a problem since at least 0.8).

Comment 1

14 years ago
Maybe bug 217120 will help
Summary: When browsing nearly any forum of other webpage, upon hitting the "back" button to return to the main site, Firefox returns me to the top of the first page, rather than leaving the window centered on where it was before. → When browsing nearly any forum of other webpage, upon hitting the "back" button to return to the main site, Firefox returns me to the top of the first page, rather than leaving the window centered on where it was before.

Comment 2

14 years ago
STill an issue?

Comment 3

14 years ago
WFM, todays build Windows XP. No reply from reporter. 

Please reopen if you can reproduce with a nighlty build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.