[RFE] Remove line-breaks in URL from clipboard

RESOLVED DUPLICATE of bug 23485

Status

SeaMonkey
Location Bar
--
enhancement
RESOLVED DUPLICATE of bug 23485
14 years ago
9 years ago

People

(Reporter: Brian Hauer, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707

When copying URLs from e-mail clients and other applications and pasting them
into Mozilla or FireFox, a common frustration is piecing together long URLs that
have become chopped up by line-breaks.  Presently, if you have received a URL
that has been chopped up, you have to cut-and-paste the first line, go back to
the URL, copy the second line, click on the URL, click again to de-focus the
auto-selection, and then paste the second part, etc.

It would be nice if Mozilla and Firefox's location bar could accept multi-line
text clipboards and just parse out the line-breaks (even better: any whitespace
characters), reconstituting the URL automatically.

Reproducible: Always
Steps to Reproduce:
1. Copy a URL from Moz, paste into Notepad.
2. Break the URL into two lines.
3. Copy the two lines back into the clipboard.
4. Paste into Moz.

Actual Results:  
Only the first line's portion of the URL appears when pasting into the location bar.

Expected Results:  
It would be nice if the line-breaks were parsed out and the URL reconstituted.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 23485 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
see bug 23485 comment 123

make a change in about:config 
editor.singleLine.pasteNewlines  integer 3
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)

> make a change in about:config 
> editor.singleLine.pasteNewlines  integer 3

Excellent.  Sorry for the dup!
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.