drag and drop selected text into url bar overwrites text already in url bar unless google search bar is opened or has already been opened once and is now closed during one firefox session

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
15 years ago
10 years ago

People

(Reporter: t35t0r, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

1) close google/searchengine bar if not already closed.
2) restart firefox
3) firefox should now be started without any searchengine bars
4) type some text into the url/location bar
5) go to some webpage and select some text and drag and drop it into the
url/location bar. The text you originally had in the url/location bar will be
overwritten and google's i'm feeling lucky will take you to the i'm feeling
lucky webpage for the text that was drag dropped into the url/location bar. It
should have appended the drag dropped text and done nothing more.

Dumb fix:
1) Now place the search bar back into the toolbar area. Right click on the
toolbar->Customize->drag and drop the search bar into the toolbar area.
2) Repeat from step (4) above and you will see that it appends the text and does
nothing more as it should.

The text should be appended irregardless of whether the search bar is visible in
the toolbar. 

But some people want stuff overwritten all the time. Then maybe one
implementation approach might be that dragging selected with left mouse button
overwrites url/location/search bar and dragging with right mouse button appends.

Reproducible: Always
Steps to Reproduce:
1) close google/searchengine bar if not already closed.
2) restart firefox
3) firefox should now be started without any searchengine bars
4) type some text into the url/location bar
5) go to some webpage and select some text and drag and drop it into the
url/location bar. The text you originally had in the url/location bar will be
overwritten.

Actual Results:  
Google's i'm feeling lucky will take you to the i'm feeling lucky webpage for
the text that was drag dropped into the url/location bar.

Expected Results:  
Append the text you drag/dropped into the url/location bar and wait for <cr>.

Comment 1

15 years ago
Can confirm. Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040624 Firefox/0.9

Comment 2

15 years ago
Can still reproduce. Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040706 Firefox/0.9.0+

Comment 3

14 years ago
Yes, this was done on purpose.  It was a bug I filed.  The assumption is that
99% of the time you are dragging and dropping a url that has not been made into
a link into the search bar because you want to go to that url.  If the url was
appended, you would end up with a mess and this feature would be useless.  I
myself have never found the behavior this bug requests, dragging and dropping to
append text, useful.  Black Ross, Asa Dotzler, and Matthew Thomas supported the
current behavior when it was implemented.  It's bug 57228 .

Comment 4

14 years ago
Haha, I also see that timeless opposed the current behavior at the time and he's
on this bug's mailing list!  So we clash again, after 5 years :)

Anyway, the previous firefox version of this bug was 176675.

Comment 5

14 years ago
yes, i sort of watch everything. i'll have to keep this in mind when i go
shopping for another browser. note that i tend to do things like drag an email
address from a bug, or a talkback incident id, or just a bug number, none of
these things do the right thing if i stick them into the urlbar, i need to stick
them after another magic word or into a url in order for them to be useful.

Comment 6

14 years ago
Wait, so for instance, if you drag a bug number into the url bar, and if firefox
behaved as you wish, you should still have to do either some typing or some
handy manipulation with dragging and cutting in order to properly insert the new
bug number into the url and delete the old bug number.  Hardly seems worth it to
me, I'd just ctrl-c, ctrl-l, shift-select desired text to replace, ctrl-v.  Or
just copy the text, select the text to be replaced, and either hit the paste
button or right-click>paste.  But to each his own.

Comment 7

13 years ago
This bug should be WONTFIX I think, unless it's changed to something like 'Add
hidden pref to append instead of overwrite Location Bar and Search Bar text'

I agree things aren't ideal right now, behaviour good be better, see Bug 250622
and Bug 250074 but never the less I think the developers have spoken on this
one.   	
(Reporter)

Comment 8

13 years ago
:(((

Comment 9

13 years ago
Mass edit: Changing QA to default QA Contact
QA Contact: davidpjames → password.manager

Comment 10

13 years ago
Mass edit: Setting correct QA for location bar/autocomplete. My bad. I forgot I had once been Autocomplete QA too. Hmm, why can't I just set the QA of bugs to the default QA of the component in a mass edit rather than having to do it manually...?
QA Contact: password.manager → location.bar
Assignee: bugs → nobody
WONTFIX for the reasons in comment 3

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.