FTP dead when proxy settings->manual & involve authentication

VERIFIED DUPLICATE of bug 15594

Status

()

Core
Networking
P3
critical
VERIFIED DUPLICATE of bug 15594
18 years ago
18 years ago

People

(Reporter: Tom Canova, Assigned: Gagan)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

18 years ago
I am using Build 2000012415
I currently have proxies set to manual. The ftp and http proxy are both set to 
our corporate firewall proxy.  This proxy requires authentication.
HTTP is now working since the proxy authentication patch for bug 22405 was 
applied.  FTP does not work at all when my proxy is set to manual- in other 
words:
If I enter the URL
ftp://www.mozilla.org/pub/mozilla/nightly/
which should return a directory listing, nothing happens except the message in 
the status bar says "Beginning FTP transaction."  No log messages are displayed 
in the dos log window, the throbber never throbs, and the screen acts as if I 
have not even clicked on anything.

If, instead of entering a url for an ftp directory listing, I enter a specific 
URL for a file, such as
ftp://ftp.mozilla.org/pub/mozilla/nightly/2000-01-25-17-M14/mozilla-win32.zip I 
get the exact same response: status="Beginning FTP transaction", no log 
messages, throbber does nothing, other than status bar message - current window 
is unchanged.

If I click on a link instead of manually entering the URL I still experience the 
same behavior.

NOW - If I change my proxy setting to direct connection to the internet and I 
try to ftp files from our intranet, the ftp functionality works just fine.

Because of this, I suspect that the problem is related to proxy authentication 
on the ftp channel.  I noticed that the changes to fix bug 22405 were applied to 
the http channel.  I suspect that something similar needs to be done for the ftp 
channel.

Updated

18 years ago
Keywords: beta1
Target Milestone: M14

Comment 1

18 years ago
PDT+
Whiteboard: [PDT+]
(Reporter)

Comment 2

18 years ago
see also bug#15594
(Assignee)

Comment 3

18 years ago
this is a dup of bug 15594

*** This bug has been marked as a duplicate of 15594 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
verified dupe of 15594
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.