Click on 'get new extension/theme' opens a new window with empty personal toolbar

RESOLVED FIXED

Status

()

Toolkit
Add-ons Manager
RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: whimboo, Assigned: Steffen Wilberg)

Tracking

({fixed-aviary1.0, regression})

1.7 Branch
x86
Windows 2000
fixed-aviary1.0, regression
Points:
---
Bug Flags:
blocking-aviary1.0PR +
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040709
Firefox/0.9.0+

Open the extension or theme manager and select 'get more extensions/themes'. A
new window will be opened and contains an empty personal toolbar.

Comment 1

14 years ago
This was broken by the FastFind toolbar (http://snipurl.com/7pzq). Changing the
following line in the Startup() function of browser.js:

    if (!openerFindBar.hidden)

to something like this should fix it:

    if (openerFindBar && !openerFindBar.hidden)
Yes, this hack is working. When the fix will be checked in? The current version
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040713
Firefox/0.9.1+ just shows it.
(Assignee)

Comment 3

14 years ago
Created attachment 153076 [details] [diff] [review]
patch (as suggested by Pike)

Indeed, the extension/theme manager doesn't have a find bar...

I hope you don't mind, Pike?
Assignee: bugs → steffen.wilberg
Status: NEW → ASSIGNED
(Assignee)

Updated

14 years ago
Attachment #153076 - Flags: review?(firefox)
(Assignee)

Updated

14 years ago
Keywords: regression

Comment 4

14 years ago
(In reply to comment #3)
> I hope you don't mind, Pike?

Not at all :-)
Flags: blocking-aviary1.0RC1?
Flags: blocking-aviary1.0?

Comment 5

14 years ago
Sorry 'bout that. Thanks for cleaning up after me. Can someone check this in?
Flags: blocking-aviary1.0RC1?
Flags: blocking-aviary1.0RC1+
Flags: blocking-aviary1.0?
Flags: blocking-aviary1.0+
(Assignee)

Comment 6

14 years ago
Branch checkin 2004-07-17 02:21.
Not needed on the trunk because it doesn't have the findbar yet.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Version: unspecified → 1.0 Branch
(Assignee)

Updated

14 years ago
Attachment #153076 - Flags: review?(firefox)

Comment 7

14 years ago
*** Bug 252969 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Keywords: fixed-aviary1.0
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.