3 clicks are needed to get a pull down menu to pull down when menu doesn't already have focus.

RESOLVED DUPLICATE of bug 250208

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 250208
14 years ago
14 years ago

People

(Reporter: Greg Schussman, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2) Gecko/20040708 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2) Gecko/20040708 Firefox/0.8.0+

pulldown menus in a web page (this problem doesn't happen with the pulldown menu
in firefox's navigation toolbar) require 3 clicks to get the menu to actually
pull down.  The first click only gives the menu focus.  The second click is
ignored.  the third click pulls the menu down.  Subsequent clicks work as
expected, provided the menu hasn't lost focus by clicking somewhere else in the
mean time.

Reproducible: Always
Steps to Reproduce:
1.go to the url listed above.
2.click on a pulldown menu in that page (say, the one for "Operating System")
3.keep clicking the down arrow of the pulldown menu.  Third time works.

Actual Results:  
First click gives the menu focus.
Second click is ingnored.
Third click pulls the menu down.
Subsequent clicks alternate pulling the menu up/down.

Expected Results:  
First click should give the menu focus AND pull the menu down.
Subsequent clicks should alternate pulling the menu up/down.

This happens on firefox checked out and built yesterday.  This happens when
build against both RHEL3.0 and Fedora Core 2 (both up2date).
Probably the same as bug 250208.
(Reporter)

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 250208 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.