zip-build of Firefox doesn't start with command line option -profilemanager

VERIFIED WORKSFORME

Status

()

Toolkit
Startup and Profile System
--
blocker
VERIFIED WORKSFORME
14 years ago
9 years ago

People

(Reporter: whimboo, Assigned: Benjamin Smedberg)

Tracking

({crash, regression})

unspecified
x86
Windows 2000
crash, regression
Points:
---
Bug Flags:
blocking-aviary1.0PR -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
This bug I can reproduce only with this version of FF:

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707
Firefox/0.9.2 

I'm not able to start Firefox with the command line option "-profilemanager".
The process is stopped immediately. I also checked it with VMWare under Win98
and I can reproduce it there.

Comment 1

14 years ago
I can confirm that with Windows 2000, but Windows XP works just fine. 
Summary: Firefox doesn't start with command line option -profilemanager → Firefox doesn't start with command line option -profilemanager

Comment 2

14 years ago
Sorry, I have to withdraw my last comment. The Problem is not OS-dependend but
depends on whether you use the installer or zip version. So the profilemanager
works in the installer, but not in the zip version.
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)
> Sorry, I have to withdraw my last comment. The Problem is not OS-dependend but
> depends on whether you use the installer or zip version. So the profilemanager
> works in the installer, but not in the zip version.

Right. Today we installed the version 0.9.2 on a fresh system and all works
fine. Strange behavior. Could someone byte compare both versions where the
differences are?
(Reporter)

Updated

14 years ago
Hardware: PC → All
Summary: Firefox doesn't start with command line option -profilemanager → Zip-build of Firefox 0.9.2 doesn't start with command line option -profilemanager
(Reporter)

Updated

14 years ago
Hardware: All → PC
*** Bug 250913 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 5

14 years ago
While creating bug 253513 i noticed that this behavior also occurs for current
nightly builds. I havn't time to test the lastest builds to see since which
version this appears for 0.9.1+ branch builds.

Currently i use Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040728 Firefox/0.9.1+ 
Severity: normal → major
Flags: blocking-aviary1.0PR?
Keywords: regression
Summary: Zip-build of Firefox 0.9.2 doesn't start with command line option -profilemanager → zip-build of Firefox doesn't start with command line option -profilemanager

Comment 6

14 years ago
I also noticed the bug in the 0.9 nightlies. The last 'working' version I have
is:  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040722
Firefox/0.9.1+

Comment 7

14 years ago
OK, I tried several nightlies, and the FIRST 0.9 version that has this error is:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040725
Firefox/0.9.1+

Downloaded from:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2004-07-25-22-0.9/Firefox-win32.zip

This appears to be built late on July 25.
(Reporter)

Comment 8

14 years ago
Gregor, could you also test a current setup build of FF 0.9+ branch?

Comment 9

14 years ago
Created attachment 154681 [details]
Diff between installer (ffinst9) and zip (ffw32now9)

I compared the ZIP build vs the Setup build for:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040729
Firefox/0.9.1+

Error exists only in the Setup build.

Comment 10

14 years ago
I meant to say 'only in the ZIP build.' !!
(Assignee)

Comment 11

14 years ago
Ben/bryner, this looks like a blocker; I don't see an obvious suspect checkin.
Severity: major → blocker
Flags: blocking-aviary1.0PR? → blocking-aviary1.0PR+
(Assignee)

Comment 12

14 years ago
*** Bug 253513 has been marked as a duplicate of this bug. ***
I performed a diff of the existing files for the installer and zip builds. I
found that browser.xpt only existed in the installer build, copied it to my
components directory for my zip build installation, deleted the compreg.dat
file, started firefox.exe with the -ProfileManager switch, and the
-ProfileManager switch brought up the profile manager. This was the only file I
needed from the installer build to get -ProfileManager to work with the zip build.
I realized my diff logic was flawed since it didn't compare a working against a
non-working zip build. It turns out that the zip builds started including
compreg.dat sometime after 0.9.1 was released... the 0.9.2 release included it.
I installed the following branch zip build:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040731
Firefox/0.9.1+

I then verified -ProfileManager didn't work a couple of times. I then deleted
the compreg.dat file and -ProfileManager worked consistently.
(Reporter)

Comment 15

14 years ago
(In reply to comment #14)
> I then verified -ProfileManager didn't work a couple of times. I then deleted
> the compreg.dat file and -ProfileManager worked consistently.

Same for me. Looking at the size of the file compreg.dat shows following diff:

original:    2.857 bytes
new created: 136.544 bytes
I haven't removed several previous branch zip builds and believe the following
shows some of the inconsistency with the builds regarding compreg.dat

compreg.dat not included: 0.9.1, 7/17, 7/19, 7/22, 7/24
compreg.dat included: 0.9.2, 7/26, 7/28, 7/29, 7/31

I realize this is a separate issue but I find it strange that the installer
build would include browser.xpt and the zip build does not. Should this be
removed from the installer build or added to the zip build? I have come to
expect that the installer build contains a subset of the xpt's in the zip build.
If the -ProfileManager switch is used on the first run after removing the
compreg.dat file the following error is displayed:
Application popup: firefox.exe - Application Error : The instruction at
"0x010dafeb" referenced memory at "0x00000005". The memory could not be "written".

Talkback does not activate I assume because it is possibly too early in the
startup. Firefox will then start successfully after this error even without
clicking the ok button.

All attempts to use the -ProfileManager switch after this are successful and do
not exhibit this error.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040804
Firefox/0.9.1+

Updated

14 years ago
Keywords: crash
(Reporter)

Comment 18

14 years ago
I can't confirm the crash with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.7) Gecko/20040804 Firefox/0.9.1+ 

Could it be a WinXP only problem?
(Assignee)

Comment 19

14 years ago
1) compreg.dat is *never* supposed to be shipped. I wonder how/why we're
shipping it.

2) Maybe the crash is from bryner's patch to compare the datestamp of
compreg.dat against the .autoreg file?
(In reply to comment #19)
> 1) compreg.dat is *never* supposed to be shipped. I wonder how/why we're
> shipping it.
It is inconsistently included in the zip build as shown in comment #16 though it
has been in the zip builds very consistently as of late and there is also the
browser.xpt being part of only the installer build though this is unrelated.

> 2) Maybe the crash is from bryner's patch to compare the datestamp of
> compreg.dat against the .autoreg file?
The .autoreg file is not included in the zip build and if the compreg.dat is not
in the zip build I don't believe it is necessary to have the .autoreg file.

I did test the zip build with an .autoreg file along with the compreg.dat from
the zip build and the components are re-registered though I still get the same
error with a clean profile with no extensions. I also tested this repeatedly.
Kicking off the blocking list... we don't officially endorse zip builds. 
Flags: blocking-aviary1.0PR+ → blocking-aviary1.0PR-
(Reporter)

Comment 22

14 years ago
A lot of people i know use zip builds every day. It's a hassle to delete the
compreg.dat every time i unpack a new version. Also when you mean it is not a
blocker while zip builds aren't endorsed i hope this will be fixed soon. As the
simplest solution this file shouldn't be shipped and could be deleted during the
build process.

How big is the ratio of downloaded setup and zip-builds of Firefox? You mean
zip-builds are not endorsed but i think users who downloaded the builds should
be ask. If over 50 percent have downloaded the lastest release as zip-build it
should be repaired for future builds. The ratio won't change too much for setup
builds that we could leave them alone. 

Comment 23

14 years ago
Firefox-win32-0.9.3.zip appears to have a working Profile Manager now.  I
clicked on RUN and used...

"C:\Program Files\Mozilla\firefox\firefox.exe" -P
(Reporter)

Comment 24

14 years ago
This bug is resolved by another fix. With todays build Mozilla/5.0 (Windows; U;
Windows NT 5.0; en-US; rv:1.7.2) Gecko/20040810 Firefox/0.9.1+ the compreg.dat
contains all neccessary data and FF is starting with the profile manager without
deleting the compreg.dat manually. Same for current trunk builds.

Marking as WFM.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

13 years ago
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.