Extension registration lost after deleting chrome.rdf

VERIFIED WORKSFORME

Status

()

Toolkit
Add-ons Manager
VERIFIED WORKSFORME
14 years ago
10 years ago

People

(Reporter: whimboo, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Currently I'm planning to share profiles between different operating systems.
With an older profile I was running in trouble after moving my default profile
to another location. I changed the profile path and startet Firefox. The only
parts I could see were the main window boxes. All other parts were not visible.
I tried to get it to work and recognized that I have to delete the chrome.rdf.

After Firefox started all parts are visible but every installed extension get
lost. They are always located inside my profile folder but weren't found because
the chrome.rdf was rebuild from scratch and doesn't contains any extension
registration.

Couldn't we use the file 'extensions/Extensions.rdf' to build the extension
registration during the rebuild of the chrome registry?

Comment 1

14 years ago
afaik, this is by design, and things not listed in extensions/ won't be
recreated. So I think it's better to leave it as it is, chrome.rdf is not for
deleting.

I suggest changing severity to enhancement.

Updated

14 years ago
Depends on: 272400

Comment 2

13 years ago
chrome.rdf is no longer used - see bug 278534.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

13 years ago
v.
Status: RESOLVED → VERIFIED
Depends on: 278534
No longer depends on: 272400
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.