Closed Bug 250744 Opened 16 years ago Closed 14 years ago

shortcuts/icons for desktop/quick launch/start menu (empty folder) are created even if unchecked during installation

Categories

(Thunderbird :: Installer, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 245392

People

(Reporter: floeff, Assigned: mscott)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Thunderbird 0.7.2 (German version)

The icons in the quick start pane and desktop are always created, regardless of
what I set in the installer.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
I have had the same problems on Windows 98SE, but can only comment on the
desktop icon. I specifically requested no desktop icon and the Thunderbird 0.7.3
install routine made one anyway. The same thing happened with Firefox 0.9.3.
This also happened for both with the previous versions.
I have the same issue with Firefox 0.10.1 on several Windows 98 machines. During
install, I unchecked the option to create a desktop shortcut, but an icon was
added to the desktop anyway.
It happened to me with Firefox 1.0RC1 on Windows 2000, but I can't reproduce it.
I've unchecked the desktop icon in installer, then it was created anyway. I've
also used the Back and Next buttons, I don't know if it matters.
Noticed in french version 0.8 and 0.9
I can confirm this for Firefox 1.0 on both Win98 and WinME. The installer asks
if you want to add shortcuts to the start menu, the desktop and the quick launch
bar. If you say no to all of them, it puts icons in all three places anyway.

Bug 268732 (it's just a report; there are no follow up comments) appears to be a
duplicate of this one.
Confirming based on dupes. Similiar is the Firefox bug 245392. Please don't add
further comments for Firefox issues.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: icons in the quick start pane and desktop are always created → shortcuts/icons for desktop/quick launch/start menu (empty folder) are created even if unchecked during installation
*** Bug 268639 has been marked as a duplicate of this bug. ***
*** Bug 272778 has been marked as a duplicate of this bug. ***
*** Bug 273694 has been marked as a duplicate of this bug. ***
Issue still present in Thunderbird 1.0.2, at least in the case of the desktop
shortcut appearing even after option is unchecked during installation.
*** Bug 246791 has been marked as a duplicate of this bug. ***
In 1.0.4 en-US on Windows 2000
Unticking all icon installation options in the installer downloaded from
auto-update generates an empty Mozilla Firefox folder in the start menu.

Is this a MozApps/Toolkit issue or can the patch for Deer Park bug 245392 be
ported to fix this bug?
Flags: blocking1.8rc1?
this would be fixed by toolkit installer and thus fixed for both apps. no need
for separate bugs. 

*** This bug has been marked as a duplicate of 245392 ***
Status: NEW → RESOLVED
Closed: 14 years ago
Flags: blocking1.8rc1?
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.