mailNavigatorOverlay.js doesn't respect external mailto:

VERIFIED DUPLICATE of bug 152526

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 152526
14 years ago
10 years ago

People

(Reporter: neil@parkwaycc.co.uk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
mailto: links check a preference network.protocol-handler.external.mailto and if
that is true then mailto: links will always launch the external mailer, even if
Mail is installed. However File/New/Message and File/Send Link only check to see
if Mail is installed in which case they will never launch an external mailer.

One way of determining whether mailto: links will launch the external mailer is
to get the IO service, then use if (ioService.getProtocolHandler("mailto")
instanceof Components.interfaces.nsIExternalProtocolHandler) ...
(Reporter)

Comment 1

14 years ago
Silly me :-[

*** This bug has been marked as a duplicate of 152526 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
V/dupe.
Status: RESOLVED → VERIFIED
Keywords: helpwanted
QA Contact: benc
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.