After returning from full screen, rightclick on "navigation toolbar" does not work

RESOLVED FIXED

Status

()

Firefox
Toolbars and Customization
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: Hussam Al-Tayeb, Assigned: vlad)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040710 Firefox/0.9.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040710 Firefox/0.9.0+

After going to fullscreen using F11 and restoring back, you'll find that you
cannot rightclick an customize the navigation toolbar

Reproducible: Always
Steps to Reproduce:
1.open firefox.
2.press F11 to go to full screen
3.press F11 to go back from full screen
4.Right click on navigation toolbar
Actual Results:  
I could not right click on navigation toolbar and customize it.

Expected Results:  
I must be able to right click on navigation toolbar.
(Reporter)

Comment 1

14 years ago
This used to work in build 20040709
Flags: blocking-aviary1.0RC1?
(Reporter)

Updated

14 years ago
Keywords: regression

Comment 2

14 years ago
I am not noticing this on Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7)
Gecko/20040710 Firefox/0.9.0+, but what I am noticing is that you cannot
customize now while in full screen, and when you go back, the buttons aren't
small and have text on them, which both were disabled when I went to full screen.
(Reporter)

Updated

14 years ago
Flags: blocking-aviary1.0?

Comment 3

14 years ago
Confirming for Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040710 Firefox/0.9.0+

Was not present on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040709 Firefox/0.9.0+

Cusomize is still available on the Menubar.

When a new instance is created, Customize is available on the Toolbar but it
disappears for the Toolbar when F11 is used twice.

When returning from the F11, Icons lose their customized settings (small) and
revert to their original size.
Created attachment 152905 [details] [diff] [review]
fullscreen-fix-0.patch

The find toolbar doesn't let us blissfully stuff a value in a loop into a
single global variable anymore, expecting it to be the same for each toolbar. 
The patch saves the stuff into per-toolbar temp attributes and restores them
later.
Assignee: bugs → vladimir
Status: NEW → ASSIGNED
Flags: blocking-aviary1.0RC1? → blocking-aviary1.0RC1+
checked in on aviary.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Flags: blocking-aviary1.0RC1+ → blocking-aviary1.0RC1?
Resolution: --- → FIXED
*** Bug 250796 has been marked as a duplicate of this bug. ***
*** Bug 250865 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 9

14 years ago
Ok, I downloaded a tinderbox build and I can verify that the bug's gone.

Updated

14 years ago
Flags: blocking-aviary1.0PR?
Flags: blocking-aviary1.0?

Updated

12 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.