Idea, saving the tabs and windows

RESOLVED DUPLICATE of bug 36810

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 36810
13 years ago
13 years ago

People

(Reporter: -, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040703 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040703 Firefox/0.8

Although Mozilla/Firefox's quality and stability has improved greatly they could
have a failsafe system for the rare crashes. If a person had open a lot of pages
or something special that is hard to track again it is hard to find again.

Why not save somewhere information "we will be loading these pages" "these were
already closed" to open the last state again if the browser crashes? I have
sometimes lost ~50 tabs and had to re-search them... It's not fun. 

The feature should be quite trivial and non-bloat to implement and help greatly
when the browser crashes. (Or if it jams, the user don't have to wonder for a
while wether it comes back aroudn or not - just killing it and restarting brings
the last state anyways.. ) Some things like being able to handle sessions
(cookies) need a bit thinking though.

Reproducible: Always
Steps to Reproduce:
1. Open pages
2. Browser crashes
3. Open a new browser

Actual Results:  
I lost my open pages, have to find them again

Expected Results:  
Opened the pages from saved state
There are extensions for this too.

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 36810 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.