If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bad character in abook.mab messes up address book entry, and can't be fixed by edit UI

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Address Book & Contacts
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Ian Graham, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616

I have an address book entry that has somehow become corrupted: the relevant
string in abook.mab is:

... (28E=Ross)(28F=Thomson)(269
    =$0Aross@jrthomson.net)(26B=352-988-3807)(26E=Clermont) ... 

Note the $0A at the beginning of the email address.

As a result I am unable to properly edit this address book entry: strings
magically disappear and reappear in the edit widget, and whatever I do I can't
seem get rid of the bogus character.

I'd be happy to send the full address book to someone working on the bug -- but
for obvious reasons am reluctant to attach the entire thing to this bug report
:-;  I will attach a graphic showing what the UI fields looks like given the
current entry value 

Reproducible: Always
Steps to Reproduce:
1. 
2.
3.




I can provide the abook.mab to someone working on the bug and willing to keep
the book private.
(Reporter)

Comment 1

13 years ago
Created attachment 152867 [details]
Two GIFs showing how the bad entry displays in the address book UI 

The images are annotated to show where things look weird (although it should be
pretty obvious).
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
Ian, thanks for the test record you provided in test.ldif. 
I tested TB 1.5 (20051201), TB2 alpha, TB trunk and SM trunk rv:1.9a3pre) Gecko/20070314 SeaMonkey/1.5a  I can edit on all versions. 

After import 
- in TB2 I see the $0A
- in TB and SM trunk I don't see the $0A

On TB1.5 and TB2 as soon as I edit the record the $0 appears to be gone/not visible.

So the behavior has changed over time and for me is WFM on trunk.  I could swear this is a dupe but I can't find it. Perhaps I'm thinking of Netscape or a different product!  But why you can't edit the card in TB 1.5.10 I don't know

cc: Neil at mcow's suggestion
QA Contact: addressbook
(Reporter)

Comment 3

11 years ago
Actually, thanks to you Wayne for taking the trouble to pursue this.

In fact I too can edit the test record on TB 1.5, and doing so deletes the bad character. 

I just hadn't tried to do so in such a long time ... got used to ignoring it, I guess. 

So I will close this as WFM 
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Comment 4

11 years ago
The $0A is probably a newline character. Most XUL widgets can't display newlines properly, while textboxes depend on a preference which by default on Windows truncates the newline and any following text.
You need to log in before you can comment on or make changes to this bug.